NETWORK LABORATUVARI

DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ

EIGRP DİNAMİK ROUTING PROTOKOLÜ

Daha önce DERS 10- STATİK ROUTING başlıklı makalemizde; router sayısı arttıkça network’ümüzün karmaşıklaştığından, yazmamız gereken statik route sayısının da bu doğrultuda artacağından ve bunun büyük bir dezavantaj oluşturduğundan bahsetmiştik. Bu dezavantajı ortadan kaldırmak için OSPF, EIGRP, BGP gibi dinamik routing protokollerinden birini kullanmamız gerekir. Makalemizde EIGRP dinamik routing protokolünün çalışma mantığından bahsedip denemeler yapacağız.

EIGRP‘nin açılımı “Enhanced Interior Gateway Routing Protocol“dür. Bu protokol cisco firmasına özel geliştirilmiştir. Yani EIGRP protokolü ile yapılmış konfigürasyonu sadece cisco marka network cihazları anlayabilir. Bundan dolayı network‘ümüzde farklı marka router‘lar var ise OSPF gibi genel bir protokol kullanmak gerekir. Denemelerimizde tüm cihazlar cisco olduğu için problem olmayacaktır.

İlk önce üzerinde çalışma yapacağımız bir topoloji oluşturup, cihazlara isimlerini ve IP’lerini vereceğiz.

eigrp dinamik routing protokolü topoloji
“EIGRP TOPOLOJİ”

Daha önce DERS 8- NETWORK CİHAZLARINA İSİM VERMEK ve DERS 9- NETWORK CİHAZLARINA IP ATAMAK isimli makalelerde isim vermeyi ve IP atamayı öğrendiğimiz için daha fazla detaya girmeyeceğiz. Ayrıca kullandığımız network laboratuvar ortamına göre interface‘ler farklılık gösterebilir fakat bu farklılık denemelerimiz için çok büyük önem arz etmemektedir. Bizim topolojimizde interface‘lerin tamamı ethernet‘tir ve eth yazısıyla yani kısaltılmış şekliyle gösterilmektedir. IP’ler verildikten sonra ki durumu kontrol etmek için tüm router‘larda “show ip int brief” komutunu kullanalım.

eigrp dinamik routing protokolü 1, 2 ve 3. router'ların ip'leri
“BİRİNCİ, İKİNCİ VE ÜÇÜNCÜ ROUTER’LARIN IP’LERİ”
eigrp dinamik routing protokolü 4, 5 VE 6. router'ların ip'leri
“DÖRDÜNCÜ, BEŞİNCİ VE ALTINCI ROUTER’LARIN IP’LERİ”

1.Router’dan 2.Router’a ping testi yaptığımızda başarılı oluyor çünkü 1.Router ile 2.Router aynı da oldukları için yol biliniyor. Fakat 1.Router, 6.Router’a erişemiyor. Çünkü 6.Router farklı dadır ve yol bilinmiyor.

eigrp dinamik routing protokolü birinci router ping testi
“BİRİNCİ ROUTER PING TESTİ”

Benzer şekilde diğer router’lar da farklı ağları bilmiyor. Hepsine çok sayıda statik route yazabiliriz. Fakat yolları öğretmenin daha güzel ve kolay yöntemi dinamik routing protokolü kullanmaktır. Şimdi eigrp ile dinamik şekilde yolları öğretelim. Her bir router’a, kendisine bağlı olan network’ü öğretelim. Her bir router’a “router eigrp (isim)“, “network x.x.x.x x.x.x.x” ve “no auto-summary” komutlarını girmeliyiz.

Burada “router eigrp (isim)” komutunda isim olarak “34” yazdım. Diğer bir deyişle “34 numaralı EIGRP sistemi“ne tüm router‘ları dahil edeceğiz.

Ayrıca her bir router’a, kendisine bağlı olan network’ü “network x.x.x.x 0.0.0.0” şeklinde tanıtabiliriz. Yani mask yerine “0.0.0.0” girerek “x.x.x.x IP‘li interface‘e git ve mask bilgisini oradakinin aynısını yap” emrini vermiş oluruz. Böylece her bir network için ayrı ayrı mask girmek yerine “0.0.0.0” girerek kolaylık sağlamış olururuz. Örneğin topolojimizde “network 10.90.12.1 0.0.0.0” komutu “10.90.12.1” IP numaralı interface içerisine yani first_router isimli router‘ın ethernet 0/0 interface‘ine bakar ve mask‘in “255.255.255.0” olduğunu görür. Ardından EIGRP içeresine mask‘i “255.255.255.0” olarak kaydeder. Biz tek tek mask‘leri kontrol etmemiş oluruz.

Eigrp ayarlarımızda “no auto-summary” komutunu varsayılan olarak yani default’ta açık olarak gelen auto-summary özelliğini kapatmak için kullanacağız. Sonuç olarak amacımız, her bir router‘a bu komutları girerek erişim problemini ortadan kaldırmaktır.

eigrp dinamik routing protokolü birinci router'ın eigrp komutları
“BİRİNCİ ROUTER’IN EIGRP KOMUTLARI”
eigrp dinamik routing protokolü ikinci router'ın eigrp komutları
“İKİNCİ ROUTER’IN EIGRP KOMUTLARI”
eigrp dinamik routing protokolü üçüncü router'ın eigrp komutları
“ÜÇÜNCÜ ROUTER’IN EIGRP KOMUTLARI”
eigrp dinamik routing protokolü dördüncü router'ın eigrp komutları
“DÖRDÜNCÜ ROUTER’IN EIGRP KOMUTLARI”
eigrp dinamik routing protokolü beşinci router'ın eigrp komutları
“BEŞİNCİ ROUTER’IN EIGRP KOMUTLARI”
eigrp dinamik routing protokolü altıncı router'ın eigrp komutları
“ALTINCI ROUTER’IN EIGRP KOMUTLARI”

Komşuluklar kurulmuş mu diye bakmak için “show ip eigrp neighbors” komutu kullanılır. Örneğin topolojimize göre yani gözle gördüğümüz kadarıyla 3.Router’un 3 adet komşusu olmalıdır. Bunlar 2., 4. Ve 5. Router’lardır.

eigrp dinamik routing protokol show ip eigrp neighbors komutu üçüncü router'ın komşuları
“SHOW IP EIGRP NEIGHBORS KOMUTU- ÜÇÜNCÜ ROUTER’IN KOMŞULARI”

show ip eigrp neighbors” kontrolü diğer router’larda da yapılmalıdır. Peki son durumda 1. Router ile 6. Router arasında haberleşme var mı? Bunu öğrenmek için ping testi yapalım. Tüm router’lar yolları öğrenmiş ise ping testi başarı ile sonuçlanmalıdır.

eigrp dinamik routing protokolü birinci router'dan altıncı router'a ping testi
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A PING TESTİ”

Sonuç olarak router’ların tamamı yolları öğrenmiş oldu. Erişim problemi ortadan kalkmış oldu. Ayrıca “traceroute X.X.X.X” komutu ile de 1. Router’ın, 6.  Router‘a giderken hangi yolu seçtiğini de izleyebiliriz.

eigrp dinamik routing protokolü birinci router'da traceroute komutu
“BİRİNCİ ROUTER’DA TRACEROUTE KOMUTU”
eigrp dinamik routing protokolü traceroute komutu birinci router'ın seçtiği yol
“BİRİNCİ ROUTER’IN SEÇTİĞİ YOL”

1. Router‘da kullandığımız “traceroute” komutunu diğer router‘larda da kullanarak trafiğin aktığı yolları görebiliriz.

Erişim dinamik şekilde sağlandıktan sonra network‘e yeni bir router eklenirse; örneğin sixth_router isimli router’a, ethernet 0/1 interface‘inden new_router isimli yeni bir router bağlarsak bunu da sisteme dahil etmemiz gerekir. Bunun için sadece new_router isimli cihazda eigrp komutlarını girmeliyiz. Böylece yeni router‘ı da eigrp sistemine dahil etmiş oluruz. Statik routing kullanmış olsaydık diğer tüm router‘lara tek tek yeni bağlanan router’ın interface ip‘lerinin öğretilmesi gerekirdi. Özetle sisteme eklenen her bir router için, sadece o router da eigrp ayarları yapılarak, kolayca diğer tüm router‘ların yeni router‘dan haberdar olması sağlanır. Umarım EIGRP‘nin dinamikliği buradan anlaşılmıştır.

Kullanılan Komutlar;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

 

Test ve Kontrol Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

1. Router için;

  • ping 10.90.56.6
  • traceroute 10.90.56.6

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir