NETWORK LABORATUVARI

DERS 12- EIGRP REDISTRIBUTE İŞLEMİ – I

EIGRP REDISTRIBUTE İŞLEMİ

Redistribute, genel ifadeyle router gibi network cihazlarında konfigüre edilmiş EIGRP ayarları içerisinde tanımlanmayan ların daha sonradan EIGRP sistemi içerisine dahil edilmesi işlemidir. Redistribute işlemini laboratuvar ortamında denemeler yaparak öğreneceğiz. Bu denemeleri yapabilmek için cihazların EIGRP konfigürasyonu içerisinde tanımlanmayan bir gerekiyor ki bu ı daha sonradan EIGRP sistemine dahil ederek redistribute işlemini gerçekleştirmiş olalım. Gerekli olan bu ağ için “loopback interface“ini kullanabiliriz. Router içerisinde bir loopback interface‘i oluşturur daha sonra bir IP adresi atarız ve son olarak da bu loopback interface IP‘sini EIGRP içerisinde redistribute işlemiyle tanıtırız. Böylece başta EIGRP içerisinde tanımlanmamış olan loopback interface IP‘sini redistribute işlemiyle EIGRP sistemi içerinde duyurmuş oluruz.

İlk önce loopback interface nedir? Onu öğrenelim. Loopback sanal bir interface’dir. Fiziksel olmadığı için de her daim up durumdadır. Loopback interface‘ini router içerisinde oluştururuz ve IP atarız. Bir router içerisinde binlerce hatta milyonlarca bu interface türünden oluşturabiliriz.

Örnek-1:

Bu örnekte EIGRP redistrubute işleminde “redistribute connected” komutunu öğreneceğiz. DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde kullandığımız topolojiyi kullanacağız. Daha önce kullandığımız bir topoloji olduğu için bu konularda detaya girmeyeceğiz.

eigrp redistribute topoloji
“EIGRP REDISTRIBUTE TOPOLOJİ”

Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım ve erişim olduğundan emin olalım.

eigrp redistribute erişim kontrolü
“ERİŞİM KONTROLÜ”

6.router’un interface’lerini kontrol edelim.

eigrp redistribute interface kontrolü
“ALTINCI ROUTER’IN INTERFACE’LERİ”

Görüldüğü üzere ethernet 0/0, ethernet 0/1, ethernet 0/2 ve ethernet 0/3 interfaceleri mevcut ve sadece ethernet 0/0 interface‘ine IP atanmış ve up durumdadır. Kullandığınız laboratuvar ortamına göre bu interface’ler gigabitethernet, fastethernet, ethernet, serial… gibi farklılıklar gösterebilir. Hangi interface‘leri kullandıysak onlarda bu işlemleri yapmalıyız. Bu router’a “loopback 0interface’i oluşturalım ve “166.166.166.166” IP’sini verelim. Burada mask olarak “255.255.255.255” kullandık. Yani tek bir IP‘yi içeren bir ağ kullandık çünkü bu ağda başka bir IP‘ye ihtiyaç duymayacağız.

eigrp redistribute loopback interface oluşturma
“LOOPBACK INTERFACE OLUŞTURMA”

6.router’ın interface’lerini tekrar kontrol edelim ve loopback 0 interface’ini görelim.

eigrp redistribute altıncı router'ın loopback interface kontrolü, loopback interface nedir ne işe yarar
“ALTINCI ROUTER İÇİN LOOPBACK INTERFACE KONTROLÜ”
eigrp redistribute altıncı router'ın loopback interface konumu, loopback interface nedir ne işe yarar
“TOPOLOJİDE ALTINCI ROUTER’IN LOOPBACK INTERFACE KONUMU”

Loopback 0 interface’i 34 otonom sistem numaralı eigrp’ye ait olmadığı için erişilemez durumdadır.

eigrp redistribute altıncı router'ın loopback interface EIGRP dışında, loopback interface nedir ne işe yarar
“ALTINCI ROUTER LOOPBACK INTERFACE’İ EIGRP 34 DIŞINDA”
eigrp redistribute altıncı router'ın loopback 0 interface erişim kontrolü, loopback interface nedir ne işe yarar
“ALTINCI ROUTER’IN LOOPBACK 0 INTERFACE’İ ERİŞİM KONTROLÜ”

1.Durum: 6.router’a ait olan loopback 0’ı eigrp’ye duyuralım yani redistrubute edelim.

eigrp redistribute altıncı router'ın loopback 0 interface redistribute işlemi, loopback interface nedir ne işe yarar
“ALTINCI ROUTER’IN LOOPBACK 0 INTERFACE’İNİN REDISTRIBUTE İŞLEMİ”

Bunun için “router eigrp 34” konfigürasyonu altında “redistribute connected” komutunu kullanacağız.

eigrp redistribute altıncı router'ın loopback 0 interface redistribute işlemi konfigürasyon, loopback interface nedir ne işe yarar
“ALTINCI ROUTER’IN LOOPBACK 0 INTERFACE’İNİN REDISTRUBUTE İŞLEMİ KONFİGÜRASYONU”

Artık loopback 0 erişilebilir durumdadır. “redistribute connected” komutunu kullandık. Yani “bu router’a bağlı olan tüm interface’leri redistribute et” emrini verdik. Başka bir deyişle “bu router’a bağlı olan tüm interface’leri eigrp 34 içerisindeki tüm router’lara öğret” emrini verdik. Loopback interface‘i sanal olsa da bu router‘a direkt bağlı bir interface‘dir.

eigrp redistribute altıncı router'ın loopback 0 interface'ine ping testi, erişim başarılı, loopback interface nedir ne işe yarar
“ALTINCI ROUTER LOOPBACK 0 INTERFACE’İNE PING TESTİ”

Altıncı router‘ın 166.166.166.166 IP numaralı loopback 0 interface‘ine olan erişim probleminin ortadan kalktığını birinci router‘dan ping atarak görmüş olduk.

2.Durum: Bunun bir diğer yolu ise daha önce de yaptığımız gibi eigrp içerisinde “network 166.166.166.166 0.0.0.0” komutunu kullanmaktır. Ayrıca bunu kullanmadan önce eski kullandığımız komutu “router eigrp 34” konfigürasyonu altında “no redistribute connected” ile kaldırmayı unutmayalım.

eigrp redistribute altıncı router'ın loopback 0 interface'inin normal duyurulması, loopback interface nedir ne işe yarar
“ALTINCI ROUTER’IN LOOPBACK 0 INTERFACE’İNİN EIGRP İÇERİSİNDE NORMAL DUYURULMASI”

Bu şekilde de duyurma işlemi yapılmış oldu. Zaten bunu daha önce DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde yapmıştık. Burada tekrar amaçlı bu işlemi yaptık. Sonuç olarak yine erişim problemi kalkmış oldu.

eigrp redistribute altıncı router'ın loopback 0 interface'ine ping testi, erişim başarılı, loopback interface nedir ne işe yarar
“ALTINCI ROUTER LOOPBACK 0 INTERFACE’İNE PING TESTİ”

Kullanılan Komutlar;
1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • int loopback 0
  • ip address 166.166.166.166 255.255.255.255
  • no shut
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

1.Durumda 6.Router için;

  • en
  • conf t
  • router eigrp 34
  • redistiribute connected
  • end
  • wr

2.Durumda 6.Router için;

  • en
  • conf t
  • router eigrp 34
  • no redistiribute connected
  • network 166.166.166.166 0.0.0.0
  • end
  • wr

Test Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

1.Router için;

  • ping 10.90.56.6
  • ping 166.166.166.166

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir