NETWORK LABORATUVARI

DERS 13- EIGRP REDISTRIBUTE İŞLEMİ – II

EIGRP REDISTRIBUTE İŞLEMİ

Örnek-2:

Daha önce DERS 12- EIGRP REDISTRIBUTE İŞLEMİ – I isimli makalemizde EIGRP redistribute konusuna giriş yapıp bir önek ile denemeler yapmıştık. Şimdi yine aynı topoloji ile ikinci örneğimize devam edeceğiz.

eigrp redistribute topoloji
“EIGRP REDISTRIBUTE TOPOLOJİ”

Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım ve erişim olduğundan emin olalım.

eigrp redistribute erişim kontrolü
“ERİŞİM KONTROLÜ”

DERS 12- EIGRP REDISTRIBUTE İŞLEMİ – I isimli makalemizde “redistribute connected” komutunu kullanmıştık. Redistrubute‘ün diğer seçeneklerini görmek için soru işaretini (?) kullanalım.

eigrp redistribute soru işareti
“SORU İŞARETİ İLE KOMUTUN DEVAMINDAKİ SEÇENEKLERİ GÖRMEK”

6.router’daki mevcut eigrp konfigürasyonunu kaldırmak için “no router eigrp 34” komutunu kullanacağız.

eigrp redistribute no komutu ile konfigürasyonu kaldırmak
“NO KOMUTU İLE MEVCUT KONFİGÜRASYONU KALDIRMAK”

Konfigürasyonu kaldrımak suretiyle 6. router eigrp’den çıkarıldığı için, 1.router 6. router’a erişemeyecektir. Ping testi ile durumu kontrol edelim. Sonuç olarak 1., 2., 3., 4. ve 5. router‘lar 34 otonom sistem numaralı EIGRP içerisine alınmıştır. 6. router‘da ise herhangi bir şekilde EIGRP konfigürasyonu bulunmamaktadır. Bunu en baştan da bu şekilde konfigüre edebilirsiniz.

eigrp redistribute ping testi erişim kontrolü
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

3.router’a daha önce de öğrendiğimiz gibi statik route yazacağız. “ip route 10.90.56.0 255.255.255.0 10.90.35.5” komutunu kullanacağız. Yani “10.90.56.0 network’üne gitmek için 10.90.35.5 bacağına git” emrini vereceğiz.

eigrp redistribute statik route default route
“ÜÇÜNCÜ ROUTER’A STATİK ROUTE – ALTINCI ROUTER’A DEFAULT ROUTE YAZMA İŞLEMİ”
eigrp redistribute statik route
“ÜÇÜNCÜ ROUTER’A STATİK ROUTE YAZMA İŞLEMİ”

Trafik çift yönlü olduğu için de 6. router’a default route yazalım. “ip route 0.0.0.0 0.0.0.0 10.90.56.5” komutunu kullanacağız. Burada “0.0.0.0 0.0.0.0” bütün IP’ler bütün mask’ler anlamına geliyor. Yani “tüm IP’lerden gelen paketleri 10.90.56.5 interface’ine gönder” emrini verelim. Sonuç olarak 6. router‘ın tek komşusu var o da 10.90.56.6 IP numaralı ethernet 0/0 interface‘ine bağlı olan 10.90.56.5 IP numaralı 5. router‘dır ve gelen tüm paketler bu tarafa yönlendirilmiş olacaktır.

eigrp redistribute default route
“ALTINCI ROUTER’A DEFAULT ROUTE YAZMA İŞLEMİ”

3 ve 6 .router arasında erişim var fakat diğer router’lar hala yolu bilmiyor. Çünkü 6. router EIGRP sisteminin dışındadır, 3. router‘a statik olarak, 6. router‘a default olarak komşusu öğretildi fakat 34 otonom sistem numaralı EIGRP içerisindeki diğer router‘lar EIGRP dışarısındaki 6. router‘a giden yolları bilmiyor. Buna örnek olması açısından 3. router‘dan 6. router‘a doğru bir ping testi yapabiliriz.

eigrp redistribute ping test
“ÜÇÜNCÜ ROUTER’DAN ALTINCI ROUTER’A DOĞRU PING TESTİ”

Bu test başarılı sonuçlansa da 1. router‘dan 6. router‘a doğru yapılan ping testi başarısız olacaktır.

eigrp redistribute ping test başarısız
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A DOĞRU PING TESTİ”

Bunun için tüm router’lara statik route yazabiliriz fakat bu zor iştir. Sistemimizde diğer router’lar zaten EIGRP sistemi içerisindedir. Her bir router’da statik route yazmaktansa 3. router’da yazdığımız statik route’u eigrp içerisinde redistribute edelim ve eigrp 34 içersindeki tüm router’lar 6. router’a gitme yolunu öğrensin. Bunun için “router eigrp 34” altında “redistribute static” komutunu kullanacağız. Zaten dönüş için problem yok çünkü 6. router nereye gitmek isterse istesin herşeyi default route ile 10.90.56.5’e gönderiyor.

eigrp redistribute işlemi redistribute static
“ÜÇÜNCÜ ROUTER’DA STATİK ROUTE’IN REDISTRIBUTE İŞLEMİ İLE EIGRP’YE TANITILMASI”

şimdi 1. router‘dan 6. router‘a doğru ping testi yapalım.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Ping testi başarıyla sonuçlanmıştır yani erişim problemi kalkmış oldu. Özetleyecek olursak;

  • 3. router 6. router’a nasıl gideceğini biliyordu (statik route ile). Bunu da eigrp 34 içerisindeki tüm router’lara duyurdu (redistribute işlemi).
  • 6. router’a default route yazıldı (dönüş yolu için). Default route ile 6. router bütün paketlerini 10.90.56.5 interface’ine gönderiyor.

Sonuç olarak erişim problemi ortadan kalkmış oldu.

Kullanılan Komutlar;
1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • ip route 10.90.56.0 255.255.255.0 10.90.35.5
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • redistribute static
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • ip route 10.90.56.0 255.255.255.0 10.90.35.5
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • redistribute static
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • ip route 0.0.0.0 0.0.0.0 10.90.56.5
  • end
  • wr

 

Test Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

3.Router için;

  • ping 10.90.56.6

1.Router için;

  • ping 10.90.56.6

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir