NETWORK LABORATUVARI

DERS 14- EIGRP REDISTRIBUTE İŞLEMİ – III

EIGRP REDISTRIBUTE İŞLEMİ

Örnek-3:

Daha önce DERS 12- EIGRP REDISTRIBUTE İŞLEMİ – I ve DERS 13- EIGRP REDISTRIBUTE İŞLEMİ – II isimli makalelerimizde  EIGRP redistribute konusunda kullandığımız topoloji ile üçüncü örneğimize devam edeceğiz. Başlangıçta yaptığımız bazı işlemler önceki makalelerimizde de yapıldığı için detaya inmeyeceğiz. Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım.

eigrp redistribute topoloji
“EIGRP REDISTRIBUTE TOPOLOJİ”

EIGRP‘nin çalışıp çalışmadığından emin olabilmek için erişim kontrolü yapalım. Bunu diğer router‘lar arasında da yapabiliriz. Biz sadece 1. router‘dan 6. router‘a doğru yapılan ping testini görelim.

eigrp redistribute erişim kontrolü
“ERİŞİM KONTROLÜ”

Redistrubute diğer seçenekler görmek için yine soru işaretini (?) kullanacağız.

eigrp redistribute soru işareti
“SORU İŞARETİ İLE KOMUTUN DEVAMINDAKİ SEÇENEKLERİNİ GÖRMEK”

Örneğimize devam edebilmek için 6. router’dan eigrp’yi kaldıralım. “no router eigrp 34” komutunu kullanacağız.

eigrp redistribute no komutu ile konfigürasyonu kaldırmak
“NO KOMUTU İLE MEVCUT KONFİGÜRASYONU KALDIRMAK”

Konfigürasyonu kaldırmak suretiyle 6. router eigrp’den çıkarıldığı için, 1. router 6. router’a erişemeyecektir. Ping testi ile durumu kontrol edelim. Sonuç olarak 1., 2., 3., 4. ve 5. router‘lar 34 otonom sistem numaralı EIGRP içerisine alınmıştır. 6. router‘da ise herhangi bir şekilde EIGRP konfigürasyonu bulunmamaktadır ve 6. router eigrp’den çıkarıldığı için 1. router 6. router’a erişemeyecektir. Bunu en baştan da bu şekilde konfigüre edebilirsiniz.

eigrp redistribute ping test başarısız
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A DOĞRU PING TESTİ”

5.router’a default route yazacağız ve redistrubute işlemini yapacağız. Yani “nereye gideceğini bilmediğin paketleri 10.90.56.6 interface’ine gönder” “bu yolu eigrp 34 içerisindeki her router’a öğret”emirlerini veriyoruz.

eigrp redistribute default route yazma işlemi
“BEŞİNCİ VE ALTINCA ROUTER’A DEFAULT ROUTE YAZMA İŞLEMİ”
eigrp redistribute default route yazma işlemi ve redistribute işlemi
“BEŞİNCİ ROUTER’A DEFAULT ROUTE YAZMA VE REDISTRIBUTE YAPMA İŞLEMİ”

6.router’a da default route yazacağız.

eigrp redistribute altıncı router default route yazma
“ALTINCI ROUTER’A DEFAULT ROUTE YAZMA İŞLEMİ”

Ping testi yapacağız.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Sonuç olarak erişim problemi ortadan kalktı. 6. router‘da default route olduğu için gelen tüm paketleri 10.90.56.5 bacağına gönderiyor. 5. router‘da da default route olduğu için o da tüm paketleri 10.90.56.6 bacağına gönderiyor. EIGRP içerisindeki diğer router‘lar ise 5. router‘da bulunan default route‘u “redistribute staticredistirbute işlemi yapıldığı için öğreniyor. Böylelikle erişim problemi de ortadan kalkmış oluyor.

Dikkat edilmesi gereken husus static route ya da default route‘lar “redistribute static” komutu ile EIGRP‘ye dump edildiğidir.

Kullanılan Komutlar;
1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • ip route 10.90.56.0 255.255.255.0 10.90.35.5
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • redistribute static
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • ip route 0.0.0.0 0.0.0.0 10.90.56.6
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • redistiribute static
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • ip route 0.0.0.0 0.0.0.0 10.90.56.5
  • end
  • wr

 

Test Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

1.Router için;

  • ping 10.90.56.6

DERS 14- EIGRP REDISTRIBUTE İŞLEMİ – III” üzerine 4 yorum

  1. iki router arası default route öngörülen bir konfigirasyon değildir sanki.
    6. router ping 11.11.11.11 dediğinde 5. router da route tablosunda bulamadığında tekrar 6. routera gönderecek.
    cihazları yakarız : )
    loopa girer gibime geliyor.

    1. Merhaba,
      Haklısınız, 6. router’dan sistemde olmayan bir IP’ye ping atıldığında 5. ve 6. router arasında loop oluşur ve sonuç olarak bu bir konfigürasyon hatasıdır 🙂 Yapıcı yorumunuz için teşekkürler.
      Topolojide genel olarak redistribute mantığını anlatmak istedim. Bundan dolayı oraya odaklanmamıştım.

      1. valla 2.kez anımsamak için bakıyorum çok iyi anlatım olmuş. ccna eğitimi gibi akışı yerinde bir anlatım MAŞALLAH.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir