NETWORK LABORATUVARI

DERS 16- EIGRP TOPOLOJİ TABLOSU VE ROUTE TABLOSU

EIGRP TOPOLOJİ TABLOSU VE ROUTE TABLOSU

“show ip eigrp topology” ve “show ip route eigrp” Komutları:

Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım. Bu konuyu DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde öğrendiğimiz için detaya inmeyeceğiz.

eigrp kontrol komutlari topoloji
“EIGRP KONTROL KOMUTLARI TOPOLOJİ”

Ping testleri ile router‘lar arası erişim olduğundan emin olalım.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Bu kontrolü diğer router‘lar arasında da yapabiliriz. Sonuç olarak “EIGRP dinamik routing protokolü çalışıyor” diyebilmeliyiz.

DERS 15- EIGRP KONTROL KOMUTLARI – I isimli makalemizde “show ip eigrp neighbors” komutunu kullanmıştık. Şimdi de “show ip eigrp topology” ve “show ip route eigrp” komutlarını öğreneceğiz. Eigrp dinamik routing protokolü sisteme dahil cihazlarına tüm yolları öğretir. Bu işlem prensip olarak şu şekilde işlemektedir; öğrenilen tüm yollar eigrp topology tablosuna yazılır, ardından en kısa yol seçilir ve route tablosuna yazılır. Bunu daha iyi anlamak için aşağıdaki şemaları inceleyebilirsiniz.

eigrp topoloji tablosu şema
“EIGRP TOPOLOJİ TABLOSU ŞEMASINDA TÜM YOLLAR KAYITLI”
eigrp route tablosu şema
“EIGRP ROUTE TABLOSU ŞEMASINDA EN KISA YOL KAYITLI”

İncelememize devam etmeden önce bazı terimleri öğrenelim.

  • Cost:

    Bant genişliği ile ters orantılı olan bir değerdir. Örneğin OSPF dinamik routing protokolünde toplam metric değeri için cost değerleri kullanılır. Cost değeri ne kadar az ise o yol o kadar iyi ve kısa kabul edilir.

  • Toplam Metric:

    Toplam metric değeri en kısa yolun seçilmesinde kullanılır ve bu değerin hesaplamasında bazı metric‘ler kullanılır. Örneğin EIGRP toplam metric hesaplamasında, bir formül içerisinde; bant genişliği, yük, gecikme, güvenilirlik gibi metric‘leri kullanır.

Toplam Metric = ([K1 * bant genişliği + (K2 * bant genişliği) / (256 – yük) + K3 * gecikme] * [K5 / (güvenilirlik+ K4)]) * 256

Formülde bulunan K değerlerinin değiştirilmesiyle toplam metric‘ler değiştirilebilir. Böylece EIGRP‘nin seçmiş olduğu yola müdahale edebiliriz. Burada daha fazla detaya inmeyeceğiz. Kısaca toplam metric değeri ne kadar az ise o yol o kadar iyi ve kısa kabul edilir.

  • AD (Advertised Distance):

    Advertised kelimesi duyurulmuş, ilan edilmiş gibi anlamlara gelir. Yani aşağıda da görüldüğü üzere; A router‘ından bakıldığı zaman, B router‘ı A router‘ının next-hop router‘ıdır. Yani A kaynağından C hedefine gidilirken bir sonraki noktadır. B router‘u C hedefine olan uzaklığı için metric‘leri kullanarak toplam metric değerini hesaplar ve bunu da A kaynak router‘una raporlar, ilan eder veya duyurur. Yani advertise eder. Bu toplam metric değerine de advertised distance yani duyurulmuş mesafe denir. Kısaca AD (Advertised Distance), next-hop router ile hedef router arasındaki toplam metric değeridir.

  • FD (Feasible Distance):

    Kaynak router ile hedef router arasındaki toplam metric değeridir yani “AD (advertised distance) + kaynak router ile next-hop router arasındaki toplam metric değeri“dir. Aşağıda da görüldüğü üzere A kaynak router‘ı ile C hedef router‘ı arasındaki mesafe için bazı metric‘ler kullanılarak hesaplanan toplam metric değeri FD (feasible distance)‘dır. Feasible kelimesi olurlu, mümkün, uygulanabilir gibi anlamlara gelir. Bundan dolayı anlaşılıyor ki en kısa yol feasible distance‘ı en az olan yoldur.

  • Successor:

    En kısa yola successor denir. Şayet FD‘leri eşit iki yol var ise en kısa yol olarak ikisi de seçilir yani route tablosunda iki adet successor kaydedilir.

  • Administrative Distance:

    Sistemimizde farklı dinamik routing protokolleri var ise burada devreye administrative distance yani idari mesafe denir. Her protokolün default’ta administrative distance değerleri vardır. Örneğin EIGRP‘nin administrative distance değeri 90, OSPF‘in 110’dur. Bir sistemde birden fazla routing yöntemi kullanıldıysa en kısa yol seçimine bu değerler de dahil olur. Böylelikle öncelikler belirlenmiş olur.

AD, advertised distance, FD, feasible distance, administrative distance, eigrp

show ip eigrp topology” komutunu kullanarak topoloji tablosuna bakacağız. 5. router’da topoloji tablosunda “10.90.34.0” network’ü için 2 yol görünüyor. Bu iki yolun değerleri aynı görünüyor. Yani iki router için de FD değeri 307200, AD değeri 281600’dür. Zaten seçilen FD değeri 307200’dür.

eigrp beşinci router topoloji ve route tablosu inceleme
“BEŞİNCİ ROUTER İÇİN TOPOLOJİ VE ROUTE İNCELEME”
eigrp beşinci router topoloji tablosu
“BEŞİNCİ ROUTER TOPOLOJİ TABLOSU”

show ip route eigrp” komutunu kullanarak route tablosuna bakacağız. Aynı şekilde 5. router’da route tablosunda da 2 yol görünüyor. Çünkü iki yolunda FD değerleri aynıdır. Değerler aynı olduğu için de EIGRP dinamik routing protokolü en kısa yol olarak ikisini seçmiştir. Biri daha kısa olsaydı onu seçecekti. Sonuç olarak route tablosunda iki adet succesor vardır.

eigrp beşinci router route tablosu
“BEŞİNCİ ROUTER ROUTE TABLOSU”

Yollardan birinin değerini değiştirelim. Ethernet interface’inin default bant genişliği değeri yani öntanımlı olarak verilen bant genişliği 10.000 kbit/sec’dır. 5. router’ın ethernet 0/1 interface’inin bant genişliğini “ethernet 0/1 interface“i altında “bandwidth 50” komutu ile 50 kbit/sec yapalım. Yani çok fazla düşürelim. Böylece bu yol daha kötü ve uzun bir yol olacaktır.

eigrp beşinci router'da interface bandwidth değiştirme
“BEŞİNCİ ROUTER’DA INTERFACE BANDWIDTH DEĞİŞTİRME”

show ip eigrp topology” komutunu kullanarak topoloji tablosuna bakacağız. Topoloji tablosunda değerleri farklı iki yol görünmektedir. Yani 10.90.35.3 IP‘sinden öğrenilen yol için FD değeri 307200 iken 10.90.45.4 IP‘si için FD değeri 256051200 olmuştur. 10.90.45.4 IP‘si için FD değeri çok artmıştır. Topoloji tablosunda tüm yollar göründüğü için iki yolu da görüyoruz.

eigrp beşinci router'da interface bandwidth değiştirdikten sonra topoloji tablosu
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA TOPOLOJİ TABLOSU”

show ip route eigrp” komutunu kullanarak route tablosuna bakacağız. FD değeri düşük olan 10.90.35.3 IP‘sinin seçildiğini görüyoruz. Yani 10.90.34.0 ağına giden yol; 307200 FD değeriyle ethernet 0/0 interface‘i olarak seçilmiş ve bu en kısa yol 10.90.35.3 IP‘sinden öğrenilmiştir. Ayrıca 90 ile ifade edilen administrative distance değeridir ve bu da bize toplam metric‘in EIGRP ile hesaplandığını söylüyor. Sonuç olarak bu değerlere bakarak en iyi, en kısa yol seçildi ve route tablosuna yazıldı.

eigrp beşinci router'da interface bandwidth değiştirdikten sonra route tablosu
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA ROUTE TABLOSU”
eigrp beşinci router topoloji ve route tablosu inceleme
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA YENİ YOL”

5. router’da “traceroute 10.90.34.3 numeric” komutunu kullanarak seçilen yolu kontrol edelim. Yani 5. router 10.90.34.0 ında bulunan 10.90.34.3 IP‘li interface’e giderken hangi yolları seçerek gidiyor? ona bakacağız. Burada “numeric” ifadesi komut çıktısını hızlandırmak için kullanılmıştır. Traceroute komutu default’ta yani ön tanımlı olarak hem sembolik hem sayısal (numeric) olarak çıktı verir. Sembolik gösterimi bastırmak için traceroute komutunu numeric ifadesiyle kullanırız ve sadece sayısal sonuçları alırız. Böylece testlerimizde hızlanmış oluruz.

eigrp beşinci router'da interface bandwidth değiştirdikten sonra traceroute
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA TRACEROUTE KOMUTU İLE YOL KONTROLÜ”
eigrp beşinci router'da interface bandwidth değiştirdikten sonra traceroute komutu yeni yol şeması
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA YENİ YOL ŞEMASI”

5. router’da “traceroute 10.90.34.4 numeric” komutunu kullanarak kontrol edelim. Yani 5. router yine 10.90.34.0 ında bulunan 10.90.34.4 IP‘li interface’e giderken hangi yolları seçerek gidiyor? ona bakacağız.

eigrp beşinci router'da interface bandwidth değiştirdikten sonra traceroute komutu yeni yol 2
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA TRACEROUTE KOMUTU İLE YOL KONTROLÜ”
eigrp beşinci router'da interface bandwidth değiştirdikten sonra traceroute komutu yeni yol şeması 2
“BEŞİNCİ ROUTER’DA BANDWIDTH DEĞİŞTİRDİKTEN SONRA YENİ YOL ŞEMASI”

Özetle dinamik routing protokolü EIGRP ile en kısa yol seçilmiş oldu.

Kullanılan Komutlar;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

Test ve Kontrol Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

1. Router için;

  • ping 10.90.56.6

5. Router için;

  • en
  • int eth 0/1
  • bandwidth 50
  • end
  • wr
  • show ip eigrp topology
  • show ip route eigrp
  • traceroute 10.90.34.4 numeric
  • traceroute 10.90.34.3 numeric

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir