NETWORK LABORATUVARI

DERS 17- EIGRP METRIC HESABI

EIGRP METRIC HESABI

Daha önce DERS 16- EIGRP TOPOLOJİ TABLOSU VE ROUTE TABLOSU isimli makalemizde bazı kavramlardan bahsetmiştik. Bu makalede topolojimiz üzerinde bu konuyu detaylandıracağız. Makalelerimizde kullandığımız topolojiyi kullanalım. Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım. Bu konuyu DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde öğrendiğimiz için detaya inmeyeceğiz.

eigrp kontrol komutlari topoloji
“EIGRP KONTROL KOMUTLARI TOPOLOJİ”

Ping testleri ile router‘lar arası erişim olduğundan emin olalım.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Bu kontrolü diğer router‘lar arasında da yapabiliriz. Sonuç olarak “EIGRP dinamik routing protokolü çalışıyor” diyebilmeliyiz.

Hatırlayacak olursak; EIGRP’de en kısa yolun seçilmesinde toplam metric değeri kullanılır. Toplam metric değerinin hesabında aşağıdaki formül uygulanır;

Toplam Metric = ([K1 * bant genişliği + (K2 * bant genişliği) / (256 – yük) + K3 * gecikme] * [K5 / (güvenilirlik+ K4)]) * 256

Formüle göre toplam metric hesabında bant genişliği (bandwidth), yük (load), gecikme (delay) ve güvenilirlik (reliability) metricleri hesaba katılır. Formülde bulunan K değerleri değiştirilerek metric‘ler devreden çıkarılır veya devreye sokulur. Örneğin formülde K1 ve K2’yi 0 şeklinde K3, K4 ve K5 değerlerini 1 olarak düşünürsek;

K1=0 , K2=0 , K3=1 , K4=1 , K5=1 ,

Toplam Metric = ([K1 * bant genişliği + (K2 * bant genişliği) / (256 – yük) + K3 * gecikme] * [K5 / (güvenilirlik+ K4)]) * 256

Toplam Metric = ([0 * bant genişliği + (0 * bant genişliği) / (256 – yük) + 1 * gecikme] * [1 / (güvenilirlik+ 1)]) * 256

Toplam Metric = ([gecikme] * [1 / (güvenilirlik+ 1)]) * 256

Olur. Sonuç olarak bu durumda en kısa yolun seçilmesinde kullanılan toplam metric değerinin hesaplanmasında sadece gecikme ve güvenilirlik metric’leri etkili olacaktır. Bant genişliği ve yük değerlerinin önemi kalmamış oldu.

show ip protocols” komutu ile 1. router’da bir inceleme yapalım.

eigrp metric default degerler show ip protocols komutu
“SHOW IP PROTOCOLS KOMUTU İLE DEFAULT DEĞERLER”

Görüldüğü üzere K1 ve K3 değerleri 1 diğerleri 0’dır. Buna göre; hangi metric’ler yol seçiminde etkili? bakalım.

Toplam Metric = ([K1 * bant genişliği + (K2 * bant genişliği) / (256 – yük) + K3 * gecikme] * [K5 / (güvenilirlik+ K4)]) * 256

Toplam Metric = ([1 * bant genişliği + (0 * bant genişliği) / (256 – yük) + 1 * gecikme] * [0 / (güvenilirlik+ 0)]) * 256

Toplam Metric = (bant genişliği + gecikme) * 256

İstisnai Durum K5=0: Burada dikkat edilmesi gereken şey, eğer K5=0 şekilde verildiyse [K5 / (güvenilirlik+ K4)] ifadesi kullanılmaz. Yani [K5 / (güvenilirlik+ K4)] ifadesi çarpım durumunda olduğundan 1 kabul edilir. Diğer durumlarda formül matematiksel olarak hesaplanır.

Sonuç olarak en kısa yolun seçilmesinde kullanılan toplam metric değerinin hesaplanmasında sadece bant genişliği ve gecikme metric’leri etkili olacaktır.

Şimdi metric’lere teker teker bakalım. Örnek olması açısından yine 1. router’da “show interface ethernet 0/0” komutu ile mevcut değere bakalım.

eigrp metric interface default degerleri show interface komutu
“SHOW INTERFACE KOMUTU İLE INTERFACE’IN DEFAULT DEĞERLERİ”

MTU: Açılımı “Maximum Transmission Unit”dır yani “Maksimum İletilecek Birim”dir. Bu değer toplam metric değerinin hesabında kullanılmaz.

Bant Genişliği (Bandwidth): Görüldüğü üzere bant genişliği değeri 10.000 Kbit/sec görünmektedir. Bunu değiştirebiliriz. Bunun için 1. router’da “ethernet 0/1 interface“i altında “bandwidth” komutunu kullanırız.

eigrp metric interface bant genişliğini değiştirmek
“INTERFACE’IN BANDWIDTH’INI DEĞİŞTİRMEK”

Ethernet interface’i default’ta 10.000 Kbit/sec’dan 5000 Kbit/sec’a düşürülmüş oldu. Bant genişliğinin değişip değişmediğine yine “show interface ethernet 0/0” komutuyla kontrol edebiliriz.

eigrp metric interface bant genişliği kontrolü
“INTERFACE’IN BANDWIDTH KONTROLÜ””

Denememizi yaptıktan sonra bant genişliğini tekrar eski haline almayı unutmayalım.

Gecikme (Delay): Paketlerin hedef noktaya ulaşma süresidir diyebiliriz. Cisco firması farklı interface’ler için farklı default gecikme değeri tanımlamıştır. Örneğin bizim topolojimizdeki 1. router’ın ethernet 0/0 interface’i için delay değeri 1000 usec’tir. Bu değer de değiştirilebilir. Bunun için 1. router’da “ethernet 0/1 interface“i altında “delay” komutunu kullanırız.

eigrp metric interface delay değerini değiştirmek
“INTERFACE’IN DELAY DEĞERİNİ DEĞİŞTİRMEK”

Ethernet interface’i default’ta 1000 usec’ten 75000 usec’e artmış oldu. Bu değerin düşük olması istenir. Delay değerinin değişip değişmediğine yine “show interface ethernet 0/0” komutuyla kontrol edebiliriz.

eigrp metric interface delay değerinin kontrolü
“INTERFACE’IN DELAY DEĞERİNİN KONTROLÜ””

Burada dikkat etmemiz gereken konu şudur; interface ethernet 0/0 altında “delay 7500” komutu ile değişiklik yapmamıza rağmen “show interface ethernet 0/0” komutu ile yaptığımız kontrolde delay değerinin 75000 usec olduğunu görüyoruz. Yani 7500 girdik 75000 usec oldu. 1 adet sıfır fazla çıktı başka bir deyişle girdiğimiz değerin 10 katı gösterildi. Bunu anlamak için delay komutundan sonra soru işareti (?) kullanalım. Görüldüğü üzere delay komutundan sonra tens of microseconds şeklinde bir değer girmemiz isteniyor. Bundan dolayı gecikmenin yani delay değerinin kaç usec (microseconds) olmasını istiyorsak onda biri (1/10) kadarını delay komutu ile birlikte girmemiz gerekir. Sonuç olarak delay değerinin 75000 usec olması için “delay 7500” komutunu kullandık.

eigrp metric delay tens of microseconds
“TENS OF MICROSECONDS İFADESİ”

Denememizi yaptıktan sonra delay değerini tekrar eski haline almayı unutmayalım.

Güvenilirlik (Reliability): Örnek topolojimizde 1. router’da “show interface ethernet 0/0” komutu ile baktığımızda bu interface’in default reliability değerinin 255/255 olduğunu görüyoruz. Bu güvenilirlik değerinin %100 olduğu anlamına gelmektedir. Bu OSI modelinde bulunan veri bağı katmanı (data-link layer) ve fiziksel katmanda (physical layer) bir problem olmadığı anlamına gelmektedir. Bu katmanlarda bir problem yaşandığında güvenilirlik (reliability) değeri azalacaktır.

Bizim örneğimizde en kısa yolu bulmak için kullanılan formülde sadece K1 ve K3 değerleri 1 diğerleri 0 idi. Bu zaten default değerlerdir. Peki bu değerleri bizim değiştirmemiz mümkün müdür? Bunun için “router eigrp 34” altında “metric weights” komutu kullanılmaktadır. Bu şekilde tüm K değerleri değiştirilebilir. Burada dikkat edilmesi gereken husus aşağıdaki örnekte de gördüğümüz üzere sadece servis tipi olarak TOS 0’ın desteklendiği uyarısı verilmektedir. Bundan dolayı TOS değeri 0 seçilmelidir. Daha sonra sırasıyla K1, K2, K3, K4 ve K5 değerleri yeniden yapılandırılabilir.

eigrp metric K değerlerinin değiştirilmesi
“EIGRP’DE K DEĞERLERİNİN DEĞİŞTİRİLMESİYLE METRIC’LERİN DEĞİŞTİRİLMESİ”

EIGRP dinamik routing protokolü yukarıda bahsi geçen formülü K değerlerine göre düzenler ve metric değerlerine göre hesap yapar. Sonucunda da AD (Advertised Distance), FD (Feasible Distance) gibi değerler bulur. Bu değerlere göre de topoloji tablosunu ve ardından route tablosunu oluşturur. Sonuç olarak da aynı otonom sistem numaralı EIGRP‘ye ait tüm router‘lar mükemmel bir erişim için en iyi yolları tespit etmiş olur. Sistemimize OSPF, BGP gibi farklı dinamik routing protokolleri de dahil ise; protokole özgü olan Administrative Distance değerleri devreye girer ve yine en iyi yollar tespit edilmiş olur.

Kullanılan Komutlar;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

Test ve Kontrol Komutları;

EIGRP Komşulukları Testi – Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

Erişim Kontrolü – 1. Router için;

  • ping 10.90.56.6

K Değerlerinin Kontrolü – 1. Router için;

  • en
  • show ip protocols

Tüm Metric Değerlerinin Kontrolü – 1. Router için;

  • en
  • show interface ethernet 0/0

Bandwidth Değeri Testi – 1. Router için;

  • en
  • conf t
  • int eth 0/0
  • bandwidth 5000
  • end
  • wr
  • show interface ethernet 0/0

Delay Değeri Testi – 1. Router için;

  • en
  • conf t
  • int eth 0/0
  • delay 7500
  • end
  • wr
  • show interface ethernet 0/0

K Değerleri Testi – 1. Router için;

  • en
  • conf t
  • router eigrp 34
  • metric weights 0 1 1 1 1 1
  • end
  • wr
  • show ip protocols

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir