NETWORK LABORATUVARI

DERS 18- EIGRP PASSIVE INTERFACE

EIGRP PASSIVE INTERFACE

Eigrp konfigrasyonu ile erişimleri sağlanmış bir sistemde router‘lar birbirlerine Hello, Update, Query, Reply, ACK (Acknowledgement) gibi paketler gönderirler. Böylece sisteme eklenmiş veya sistemden çıkarılmış bir router var ise bütün router‘lar bundan haberdar olur ve eigrp komşulukları kurulur veya kaldırılır. Sonuç olarak tüm sisteme dahil tüm router‘ların topoloji ve route tabloları her daim güncel kalır. Bu makalede paketler konusunu çok detaylandırmayacağız.

Route bilgilerinin duyurulmasını veya duyurulmamasını kontrol etmek için passive-interface komutunu kullanabiliriz. Passive-interface komutu, interface’ler arasında yönlendirme güncellemeleri yapılırken bazı interface’ler üzerinden bu güncellemelerin bastırılmasını sağlar. Çoğu routing protokolünde kullanılan bu komut EIGRP içerisinde kullanıldığında iki router arasındaki hello paketlerinin değişimini bastırır. Bunun sonucunda da EIGRP komşuluğu kaybedilir. Bu hem advertise edilen yani duyurulan routing update’lerini hem de gelen routing update’lerini durdurur. Kısaca passive-interface komutu belirli bir interface’e gelen hello paket’lerini ve yine interface’den gönderilen hello paket’lerini keser.

Makalelerimizde kullandığımız topolojiyi kullanalım. Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım. Bu konuyu DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde öğrendiğimiz için detaya inmeyeceğiz.

eigrp kontrol komutlari topoloji
“EIGRP KONTROL KOMUTLARI TOPOLOJİ”

Ping testleri ile router‘lar arası erişim olduğundan emin olalım.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Bu kontrolü diğer router‘lar arasında da yapabiliriz. Sonuç olarak “EIGRP dinamik routing protokolü çalışıyor” diyebilmeliyiz.

Topolojimizde “debug eigrp packet hello” komutu ile 2. router’da bir inceleme yapalım. Görüldüğü üzere ethernet 0/0 interface’inden ve ethernet 0/1 interface’inden hello paketlerini hem gönderiyor hem alıyor.

eigrp passive-interface debug eigrp packet hello
“İKİNCİ ROUTER’DA HELLO PAKETLERİNİ İZLEMEK İÇİN DEBUG İŞLEMİ”

Hello paketleri iki router’ın da “ben buradayım” demesidir diyebiliriz. Hello paketleriyle başlayan süreç komşuluğun kurulmasıyla son bulur. Daha önce de DERS 15- EIGRP KOMŞULUKLAR isimli makalemizde öğrendiğimiz gibi 2. router’ın komşulukları kurulmuş mu? Diye bakmak için “show ip eigrp neighbors” komutunu kullanacağız. Aşağıda komut çıktısında da görüldüğü üzere hello paketlerinin gönderildiği/alındığı interface’lerden komşuluklar kurulmuştur.

  • Ethernet 0/0 interface’inden 10.90.12.1 IP’li interface ile,
  • Ethernet 0/1 interface’inden 10.90.23.3 IP’li interface ile komşuluk kurulmuştur.
eigrp passive-interface komşuluklar show ip eigrp neighbors
“İKİNCİ ROUTER’IN KOMŞULUKLARI”

2. router’da eigrp konfigürasyonunda ethernet 0/0’ı passive-interface konumuna alalım. Bunun için 2. router’da “router eigrp 34” altında “passive-interface Ethernet 0/0” komutunu kullanacağız. Bu işlemden sonra  “debug eigrp packet hello” komutu ile 2. router’da bir inceleme yapalım. Görüldüğü üzere Hello paketleri artık sadece ethernet 0/1 interface’inden yapılmaktadır. Komşuluk durumunun değiştiğine dair bir log kaydı da görülmektedir. İncelememiz bittikten sonra router’da gereksiz bir yük oluşmaması açısından debug sürecini sonlandıralım. Bunun için “no debug eigrp packet hello” komutunu kullanacağız.

eigrp passive-interface komutu
“İKİNCİ ROUTER’DA PASSIVE-INTERFACE KOMUTU”

Gerçekten komşuluk düşmüş mü? Bunun kontrolünü daha önce öğrendiğimiz gibi “show ip eigrp neighbors” komutu ile yapalım. Görüldüğü üzere sadece ethernet 0/1 interface’i üzerinden 10.90.23.3 IP’li interface arasında komşuluk vardır. Diğer komşuluk düşmüştür. Çünkü diğer interface passive konumdadır.

eigrp passive-interface komutu sonrası komşuluklar
“PASSIVE-INTERFACE SONRASI KOMŞULUKLAR”

2. router’da “router eigrp 34” altında “no passive-interface ethernet 0/0” komutunu kullanarak sistemimizi tekrar eski haline alalım. “show ip eigrp neighbors” komutu ile diğer komşuluğun tekrar geldiğini görelim.

eigrp no passive-interface komutu
“İKİNCİ ROUTER’DA NO PASSIVE-INTERFACE KOMUTU”

Sonuç olarak passive-interface komutunu kullanmadan önce 2. routerrouter eigrp 34” konfigürasyonu altında tanımlanmış network’ler ethernet 0/0 ve ethernet 0/1 inteface’inden duyuruluyordu. Fakat “passive-interface Ethernet 0/0” komutu ile 2. router’a “bu bilgileri ethernet 0/0 interface’inden duyurma” emrini vermiş olduk. Böylece bu interface’e bağlı network’teki tüm router’lar, 34 otonom sistem numaralı eigrp’den bihaber oldu ve komşuluklar düştü. 2. router’da eigrp konfigürasyonu altında nelerin var olduğunu görmek için “show running-config | section eigrp” komutunu kullanabiliriz. Bu komut ile “çalışan konfigürasyonda içerisinde (running-config) eigrp kelimesinin geçtiği bölümleri (| section eigrp) göster (show)” emrini vermiş oluyoruz.

eigrp passive-interface show run | section eigrp komutu
“İKİNCİ ROUTER’UN TÜM EIGRP KONFİGÜRASYONU”

Passive-interface komutunu update paketlerini göndermek istemediğimiz interface’ler için kullabiliriz. Eğer cihazımızda çok fazla sayıda interface var ve sadece bir ikisinde duyurma işlemi yapacaksak “passive-interface default” komunu kullanabiliriz. “passive-interface default” komutu ile router’ın tüm interface’leri passive konuma getirilir ve sadece duyurma işlemi yapacağımız interface’ler için “no passive-interface” komutunu kullanılır. Örnek olması açısından 2. router’da “router eigrp 34” konfigürasyonu altında “passive-interface default” komutunu kullanalım ve ardından yine “router eigrp 34” altında “no passive-interface ethernet 0/1” komutunu kullanalım. “show ip eigrp neighbors” komutu ile komşulukları kontrol edelim. Görüldüğü üzere komşuluk sadece ethernet 0/1 interface’i için kurulmuş diğeri passive konumda olduğu için düşmüştür.

eigrp passive-interface default komutu
“İKİNCİ ROUTER’DA PASSIVE-INTERFACE DEFAULT KOMUTU”

Network laboratuvarımızda incelemelerimize makalelerimiz ile devam edebilmek için yaptığımız değişiklikleri iptal edip eski haline almayı unutmayalım.

Kullanılan Komutlar;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

Test ve Kontrol Komutları;

EIGRP Komşulukları Testi – Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

Erişim Kontrolü – 1. Router için;

  • ping 10.90.56.6

Passive-Interface Testi – 2. Router için;

  • en
  • conf t
  • router eigrp 34
  • passive-interface ethernet 0/0
  • end
  • wr
  • debug ip eigrp packet hello
  • sh ip eigrp neighbors

No Passive-Interface Testi – 2. Router için;

  • en
  • conf t
  • router eigrp 34
  • no passive-interface 0/0
  • end
  • wr
  • debug ip eigrp packet hello
  • sh ip eigrp neighbors

Passive-Interface Default Testi – 2. Router için;

  • en
  • conf t
  • router eigrp 34
  • passive-interface default
  • no passive-interface ethernet 0/1
  • end
  • wr
  • debug ip eigrp packet hello
  • sh ip eigrp neighbors

Debug Testini Kapatmak – 2. Router için;

  • en
  • no debug eigrp packet hello

DERS 18- EIGRP PASSIVE INTERFACE” üzerine 2 yorum

    1. komutu # modda kullanman gerek.
      yada router1(config)# –> burda isen “do debug eigrp packet hello” kullanabilirsin

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir