NETWORK LABORATUVARI

DERS 20- EIGRP ACTIVE VE PASSIVE STATE

Daha önce DERS 16- EIGRP TOPOLOJİ TABLOSU VE ROUTE TABLOSU isimli makalemizde topoloji ve route tablosundan bahsetmiştik. Burada sadece active state ve passive state yani aktif durum ve pasif durumdan bahseceğiz.

Topoloji tablosunda aktif durum A harfi ile pasif durum P harfi ile gösterilmektedir. Topoloji tablosunda hedef network aktif durumda ya da pasif durumda olabilir. Router hedef network’e ulaşmak için hesaplama yapmış ve toplam metric değerini bulmuş ise FD (Feasible Distance)’ı küçük olan yol da successor olarak seçilmiştir. Yani artık en kısa ve iyi yol seçilmiştir. Bu durumda hedef network pasif durumdadır. Eğer bir router’ın o an için successor’ü yok ise hemen yeniden hesaplama (recalculation) yapılır. Hesaplama işlemi yapılırken router aktif duruma geçmiş demektir. Aktif durumda router’lar, komşularına hedef network ile ilgili sorularını, query paketleri aracılığıyla sorar. Komşulardan hedef network’e giden yolar ile ilgili bilgisi olanlar, reply paketleri ile cevap dönerler. Bilgisi olmayan komşular da kendi komşularına query paketleri ile sorguyu aktarırlar. Tüm bu işlem bittikten sonra topoloji tablosunda hedef network’e ait durum pasif konuma geçer. Son olarak router successor’ünü seçer ve route tablosuna yazar.

Kısaca router hedef network için o an bir hesaplama yapmıyorsa passive state’te, hesaplama yapıyor ise aktive state’tedir.

Makalelerimizde kullandığımız topolojiyi kullanalım. Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım. Bu konuyu DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde öğrendiğimiz için detaya inmeyeceğiz.

eigrp kontrol komutlari topoloji
“EIGRP KONTROL KOMUTLARI TOPOLOJİ”

Ping testleri ile router‘lar arası erişim olduğundan emin olalım.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Bu kontrolü diğer router‘lar arasında da yapabiliriz. Sonuç olarak “EIGRP dinamik routing protokolü çalışıyor” diyebilmeliyiz.

2. router’da “show ip eigrp topology” komutu ile topoloji tablosunu inceleyecek olursak tüm hedef network’lere ilişkin durumlar pasif görünmektedir. Yani tüm hesaplamalar yapılmış, pasif duruma geçilmiş ve topoloji tablosuna veriler yazılmıştır. Yorumlayacak olursak, 2. router,

  • 10.90.45.0 255.255.255.0 hedef network’ünü ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş ve durum passive state’e geçmiştir.
  • 10.90.56.0 255.255.255.0 hedef network’ünü ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş ve durum passive state’e geçmiştir.
  • 10.90.12.0 255.255.255.0 hedef network’ü router’a ethernet 0/0 interface’inden direk bağlıdır ve durum passive state’e geçmiştir.
  • 10.90.35.0 255.255.255.0 hedef network’ünü ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş ve durum passive state’e geçmiştir.
  • 10.90.23.0 255.255.255.0 hedef network’ü router’a ethernet 0/1 interface’inden direk bağlıdır ve durum passive state’e geçmiştir.
  • 10.90.34.0 255.255.255.0 hedef network’ünü ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş ve durum passive state’e geçmiştir.

Son olarak da “show ip route eigrp” komutu ile route tablosuna baktığımızda successor‘lerin de seçildiğini görebiliyoruz.

eigrp active state passive state topoloji tablosu route tablosu
“İKİNCİ ROUTER İÇİN TOPOLOJİ TABLOSUNDA ACTİVE STATE VE PASSIVE STATE İNCELEMESİ”

Kullanılan Komutlar;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

Test ve Kontrol Komutları;

EIGRP Komşulukları Testi – Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

Erişim Kontrolü – 1. Router için;

  • ping 10.90.56.6

Active State ve Passive State İncelemesi – 2. Router için;

  • en
  • show ip eigrp topology
  • show ip route eigrp

 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir