NETWORK LABORATUVARI

DERS 22- EIGRP STUB KONFİGÜRASYONU – II

Temel Eigrp Stub Uygulaması

DERS 21- EIGRP STUB KONFİGÜRASYONU – I isimli makalemizde bahsettiğimiz gibi stub router olarak konfigüre edilmiş remote router’ın merkezde tek bir eigrp komşusu vardır, tek bir çıkış yolu vardır, transit trafiğe kapalıdır.

Merkezdeki router’a distribution router, şubelerdeki router’lara remote router denir ve genelde bu tip hub-spoke yapılarda remote router’larda gerekli konfigürasyon yapılarak stub router yapılır. Remote router’lar summary route’lar, connected route’lar, redistributed static route’lar, external route’lar ve internal route’lar için query paketlerine “inaccessible” cevabını verir.  Bu büyük ölçüde remote router’ların query paketlerine cevap vermesiyle ilgili yükü azaltacaktır. Stub router aynı zamanda komşusuna özel peer bilgisini gönderir.

Konfigürasyon işlemi için “router eigrp 34” altında “eigrp stub” komutunu kullanacağız. Farklı seçenekleri görmek için eigrp konfigürasyonu olan herhangi bir router‘da komuttan sonra soru işaretini (?) kullanalım yani “router eigrp 34” altında “eigrp stub ?” komutunu girelim.

eigrp stub komutu seçenekleri soru işaretleri
“EIGRP STUB KOMUTU SEÇENEKLERİ”

Bu seçenekleri açıklayacak olursak;

Connected: Stub router merkez router’a, kendisine bağlı olan route’ları duyurur. Redistribution’a gerek yoktur.

Receive-only: Stub router hiçbir route bilgisi göndermez.

Static: Stub router merkez router’a, sadece statik route’ları duyurur. Statik route’ların eigrp içerisinde redistirbute edilmesi gereklidir.

Summury: Stub router merkez router’a, summury edilmiş route’ları duyurur.

Redistributed: Stub router merkez router’a, redistribute edilmiş tüm route’ları duyurur.

Denemelerimizi yapabilmek için DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde kullandığımız topolojiyi kurduk.

eigrp kontrol komutlari topoloji
“EIGRP TOPOLOJİ”

Fakat router‘ların yerlerini değiştirerek aşağıdaki gibi şekillendirdik. Yani;

  • MERKEZ: 2. router,
  • ŞUBE-1: 3. router:
  • ŞUBE-2: 1. router,

şeklinde kabul edelim. Görüldüğü üzere şube-1’in arkasında 4., 5. ve 6. router’ı içeren farklı bir network daha var.

eigrp stub konfigürasyonu için hub-spoke topolojisi
“EIGRP STUB UYGULAMASI İÇİN HUB-SPOKE TOPOLOJİ”

Hiçbir stub konfigürasyonu yapmadan merkezden eigrp topoloji ve eigrp route tablolarını inceleyelim. Merkez router’da yani 2. router’da “show ip eigrp topology” ve “show ip route eigrp” komutlarını kullanalım. DERS 16- EIGRP TOPOLOJİ TABLOSU VE ROUTE TABLOSU isimli makalemizde de bahsettiğimiz gibi eigrp topoloji tablosunda tüm yollar, eigrp route tablosunda sadece successor’ler yani en iyi yollar yazılmıştır. Eigrp route tablosuna göre;

  • 10.90.34.0/24 network’ünü kendi ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş.
  • 10.90.35.0/24 network’ünü kendi ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş.
  • 10.90.45.0/24 network’ünü kendi ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş.
  • 10.90.56.0/24 network’ünü kendi ethernet 0/1 interface’inden ve 10.90.23.3 IP’sinden öğrenmiş.

Yorumlayacak olursak 10.90.23.0/24 ve 10.90.12.0/24 network’ü kendisine direk bağlıdır. Zaten bunu eigrp topoloji tablosunda da görüyoruz.

eigrp stub öncesi eigrp topoloji ve eigrp route tablosu
“STUB KONFİGÜRASYONU ÖNCESİ EIGRP TOPOLOJİ VE ROUTE TABLOSU”

Şimdi şubeleri stub yapalım ve route tablosunda neler değişiyor? gözlemleyelim. Bunun için şubelerde yani 3. ve 1. router’da “router eigrp 34” konfigürasyonu altında “eigrp stub” komutunu kullanalım. Daha sonra “sh run | sec eigrp” komutu ile girilen tüm eigrp konfigürasyonunu kontrol edelim.

eigrp stub üçüncü router'ın eigrp stub konfigürasyonu
“ŞUBE-1’İN EIGRP STUB KONFİGÜRASYONU”
eigrp stub birinci router'ın eigrp stub konfigürasyonu
“ŞUBE-2’NİN EIGRP STUB KONFİGÜRASYONU”

Görüldüğü üzere stub konfigürasyonu girilir girilmez stub olan router komşularına peer bilgisinin değiştiğine dair bir mesaj gönderiyor. Ayrıca “eigrp stub” komutunu direk kullandığımızda default’ta yani ön tanımlı olarakeigrp stub connected summary” kullanılmış. Yani şube, kendisine direk bağlı network’leri ve summary edilmiş route’ları dâhil ederek stub olmuş. Şimdi merkezdeki eigrp route tablolarını tekrar inceleyelim.

eigrp stub sonrası eigrp topoloji ve eigrp route tablosu
“STUB KONFİGÜRASYONU SONRASI EIGRP TOPOLOJİ VE ROUTE TABLOSU”

Merkezdeki distribution router’un eigrp topoloji ve eigrp route tablosuna baktığımızda; merkez tarafından kendisine bağlı olan 10.90.12.0/24 ve 10.90.23.0/24 network’leri biliniyor. Ayrıca şube-1’de kullanılan 3. router’a direk bağlı olan 10.90.34.0/24 ve 10.90.35.0/24 network’leri biliniyor. Bunların bilinmesi “eigrp stub” komutuna ilişkin “connected” seçeneği ile sağlanmıştır. Aşağıda merkez router’ın gördüğü network’ler gösterilmiştir.

eigrp stub merkez router'ın gördüğü network'ler
“MERKEZ ROUTER’IN GÖRDÜĞÜ NETWORK’LER”

Merkez router’dan bu network’lere ping testleri yapalım. Testler başarılı olacaktır.

eigrp stub konfigürasyonu sonrası ping testi
“STUB KONFİGÜRASYONU SONRASI PING TESTİ”

Merkez router’dan route tablosunda olmayan network’lere ping testleri yapalım. Testler başarısız olacaktır.

eigrp stub konfigürasyonu sonrası ping testi basarisiz
“STUB KONFİGÜRASYONU SONRASI BAŞARISIZ SONUÇLANAN PING TESTİ”

Görüldüğü üzere bir router’ı stub router olarak tanımlamak; “ben son noktayım” demektir. Yani hub-spoke topolojilerinde şube son noktadır, bundan dolayı şubelerdeki router’lar remote router’lardır ve stub olarak konfigüre edilir.

Kullanılan Komutlar;

IP Atama ve EIGRP Konfigürasyonu;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

Eigrp Stub Konfigürasyonu;

1. ve 3. Router için;

  • en
  • conf t
  • router eigrp 34
  • eigrp stub ?

1. Router için;

  • en
  • conf t
  • eigrp router 34
  • eigrp stub
  • end
  • wr

3. Router için;

  • en
  • conf t
  • eigrp router 34
  • eigrp stub
  • end
  • wr

Test ve Kontrol Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors
  • show run | sec eigrp

2. Router için;

  • en
  • show ip eigrp topolgy
  • show ip route eigrp
  • ping 10.90.56.6
  • ping 10.90.35.5
  • ping 10.90.35.3
  • ping 10.90.34.4
  • ping 10.90.34.3
  • ping 10.90.23.3
  • ping 10.90.12.1
  • ping 10.90.56.5
  • ping 10.90.56.6
  • ping 10.90.45.5
  • ping 10.90.45.4

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir