NETWORK LABORATUVARI

DERS 25- EIGRP STUB KONFİGÜRASYONU – V

Eigrp Stub Leak-Map Uygulaması

Topolojimizdeki tüm router’ları 34 otonom sistem numaralı eigrp içerisinde konuşturalım.

eigrp redistribute topoloji
“IP’LER”

Topolojimizdeki router’ların yerlerini değiştirerek hub-spoke yapısına benzetelim.

eigrp stub konfigürasyonu için hub-spoke topolojisi
“EIGRP STUB UYGULAMASI İÇİN HUB-SPOKE TOPOLOJİ”

EIGRP konfigürasyonunu DERS 22- EIGRP STUB KONFİGÜRASYONU – II isimli makalemizde yaptığımız için detaya girmedik.

Şimdi Şube-2’yi kendisine bağlı interface’ler ile stub yapalım. Ardından sırasıyla; Şube-1’de 10.90.56.0/24 ve 10.90.12.0/24 network’ünü Access-list ile işaretleyelim, bu Access-list’i Route-map’e bağlayalım ve Şube-1’i kendisine bağlı interface’ler ve route-map’teki network’ler ile stub yapalım. Adım adım yapacak olursak,

  • Şube-2 için;

Şube-2’yi kendisine bağlı interface’ler ile stub yapalım. Yani 1. Router’da “router eigrp 34” konfigürasyonu altında “eigrp stub connected” komutunu kullanalım.

temel eigrp stub konfigürasyonu
“ŞUBE-2 EIGRP STUB KONFİGÜRASYONU”
  • Şube-1 için;

A. Şube-1’de 10.90.56.0/24 ve 10.90.12.0/24 network’ünü isimli Access-list ile işaretleyelim. Yani 3. Router’da “ip access-list standard ACL-TEST” komutu ve “permit 10.90.56.0 0.0.0.255”, “permit 10.90.12.0 0.0.0.255” komutlarını kullanalım. Sonuç olarak Access-list ile 10.90.56.0/24 ve 10.90.12.0/24 network’lerine permit komutu ile izin verelim yani bir nevi işaretleyelim.

B. 3.router’da bulunan ACL-TEST isimli Access-list’i RM-TEST isimli Route-map’e bağlayalım. Yani 3. Router’da “route-map RM-TEST” ve “match ip address ACL-TEST” komutlarını kullanalım. Sonuç olarak Route-map‘in kapsadığı network’leri Access-list ile belirlemiş olalım.

C. Şube-1’i kendisine bağlı interface’ler ve route-map’teki interface’ler ile stub yapalım. Yani 3. Router’da “router eigrp 34” konfigürasyonu altında “eigrp stub connected leak-map RM-TEST” komutunu kullanalım. Sonuç olarak bu komut ile stub‘a hem bağlı network’leri hem RM-TEST isimli Route-map‘in kapsadığı network’leri dahil etmiş olalım.

eigrp stub leak-map konfigürasyonu
“ŞUBE-1 EIGRP STUB LEAK-MAP KONFİGRASYONU”

Şube-2’den 10.90.56.0/24 network’üne erişim olacak fakat 10.90.45.0/24 network’üne erişim olmayacaktır. Çünkü Şube-1’in arkasında bulunan 10.90.45.0/24 network’ünü Şube-1’de stub‘a dahil etmedik. Bunu ping testi ile kontrol edebiliriz.

eigrp stub leak-map ping testi
“ŞUBE-2’DEN PING TESTİ”

Aynı zamanda bunu Şube-2’nin router’unun yani 1. Router’un route tablosunda da görebiliriz. Route tablosunda 10.90.45.0/24 network’ü yoktur.

eigrp stub leak-map route tablosu
“ŞUBE-2’NİN ROUTE TABLOSU”

Route tablosunda 10.90.12.0/24, 10.90.23.0/24, 10.90.34.0/24, 10.90.35.0/24 ve 10.90.56.0/24 network’leri vardır.  Bu network’ler öğrenilmiştir. Fakat Route tablosunda 10.90.45.0/24 network’ü yoktur. Sonuç olarak leak-map ile stub konfigürasyonuna dâhil ettiğimiz network’lere erişim sağlanmıştır.

Kullanılan Komutlar;

IP Atama ve EIGRP Konfigürasyonu;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

STANDARD ACCESS-LIST Konfigürasyonu;

3. Router için;

  • en
  • conf t
  • ip access-list standard ACL-TEST
  • permit 10.90.56.0 0.0.0.255
  • permit 10.90.12.0 0.0.0.255
  • end
  • wr

ROUTE-MAP Konfigürasyonu;

3. Router için;

  • en
  • conf t
  • route-map RM-TEST
  • match ip address ACL-TEST
  • end
  • wr

Eigrp Stub Konfigürasyonu;

1. ve 3. Router için;

  • en
  • conf t
  • router eigrp 34
  • eigrp stub ?

1. Router için;

  • en
  • conf t
  • eigrp router 34
  • eigrp stub connected
  • end
  • wr

3. Router için;

  • en
  • conf t
  • eigrp router 34
  • eigrp stub connected leak-map RM-TEST
  • end
  • wr

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir