NETWORK LABORATUVARI

DERS 26- OSPF DİNAMİK ROUTING PROTOKOLÜ

OSPF protokolü dinamik routing protokollerinden biridir. OSPF‘in açılımı “Open Shortest Path First” yani “İlk Açık Yöne Öncelik“tir. Şimdi bu protokolü anlayabilmek için bir örnek yapalım. İlk olarak topolojimizi oluşturup, IP’lerimizi veriyoruz.

ospf protokolü topoloji
“OSPF Protokolü İçin Örnek Topoloji”
ospf topology ip
“OSPF TOPOLOJİSİ İÇİN IP’LER”

IP verme işlemini daha önceki NETWORK CİHAZLARINA IP ATAMAK makalemizde anlattığımız için detaya girmeyeceğiz. Router’larımıza loopback 0 IP’lerini de atayalım ve verdiğimiz tüm IP’leri kontrol etmek için “show ip interface brief” komutunu kullanalım.

ospf protokolü için IP'ler
“1., 2. ve 3. Router İçin IP Bilgileri”
ospf protokolü için IP'ler
“4., 5. ve 6. Router İçin IP Bilgileri”

Dikkat edilecek olursa router’lara loopback 0 adresi de atadık. Router’lar bu loopback’leri Neighbor ID olarak kullansın diye atıyoruz.

1.Router’dan 2.Router’a ping testi yaptığımızda başarılı oluyor çünkü 1.Router ile 2.Router aynı ağda oldukları için yol biliniyor. Fakat 1.Router, 6.Router’a erişemiyor. Çünkü 6.Router farklı ağdadır ve yol bilinmiyor.

ospf ping testi
“PING TESTİ”

Benzer şekilde diğer router’lar da farklı ağları bilmiyor. Hepsine bir sürü statik route yazabiliriz. Fakat yolları öğretmenin daha güzel yöntemi dinamik routing protokolü kullanmaktır. OSPF ile dinamik şekilde yolları öğretelim. İlk önce topolojimizi area denilen alanlara 0’dan başlayarak bölmeliyiz.

ospf area
“OSPF AREA’LAR”

Daha sonra da her bir router’a, kendisine bağlı olan network’ü öğretmeliyiz. Burada önemli olan hangi area’ya hangi router’ın hangi interface’i dâhil olduğunu bilmek. Bizim topolojimize göre;

area 0 : R3-e0/0, R3-s1/0, R1-e0/0, R1-s1/0, R2-e0/2, R2-e0/3

area 1 : R2-e0/0, R2-e0/1, R4-0/0, R4-e0/1

area 2 : R4-e0/2, R4-e0/3, R5-e0/0, R6-e0/0

Bu listeye dikkat ederek her bir router’a “router OSPF (rakam)” ve “network x.x.x.x x.x.x.x area (rakam)” komutlarını girmeliyiz. Örneğin 1. Router için aşağıdaki gibi komut girmeliyiz.

 

  • router ospf 1
  • network 10.90.12.1 0.0.0.0 area 0
  • network 10.90.13.1 0.0.0.0 area 0

Topolojimizde 1. Router; 1 adet ethernet 1 adet de serial olmak üzere 2 adet interface sahiptir. Görüldüğü üzere kendisi üzerinde bulunan tüm networkleri OSPF’e dahil etmek istediğimiz için 2 interface’ine ait network bilgisini de ayrı ayrı OSPF içerisinde network komutu ile yazdık. Aynı şekilde diğer tüm router’ların fiziksel interface’leri OSPF konfigürasyonuna dahil edelim.

Hatırlatmak gerekirse loopback 0 interface’leri sanal interface’lerdir. Burada loopback interface’lerini Neighbor ID olarak kullanacağımız için  atamıştık. Bundan dolayı loopback’leri OSPF’e dahil etmeye gerek yoktur.

 

show running-config | section ospf” komutu ile tüm konfigürasyon içerisinde “ospf” kelimesi geçen kısımları görelim yani girdiğimiz OSPF komutlarını kontrol edelim.

ospf konfigürasyonu
“1.,2. VE 3. ROUTER İÇİN OSPF KONFİGÜRASYONU”
ospf konfigürasyonu
“4.,5. VE 6. ROUTER İÇİN OSPF KONFİGÜRASYONU”

Komutlarımızı doğru girip girmediğimizi yukarıdaki gibi kontrol edebildiysek ping testimizi yapalım. Bakalım tüm router’lar yolları öğrenebilmiş mi? 1.Router’dan 2.Router’a ping testi yaptığımızda başarılı oluyor çünkü 1.Router ile 2.Router aynı ağda oldukları için zaten yol biliniyor. Fakat 1.Router, 6.Router’a erişemiyor. Çünkü area’lar arasında bir köprü kurulmamıştır.

ospf ping testi
“PING TESTİ”

Topolojimizde 4. Router ve 2. Router olmak üzere iki adet “ABR” (Area Border Router) vardır. Yani bunlar area’lar arasındaki sınır routerlarıdır.

ospf abr (area border router) routerospf abr router
“ABR ROUTER’LAR”

Bu area’lar arasındaki köprüye “virtual-link” denir. “Virtual-link” işlemi ABR ’lar arasında “area (rakam) virtual-link (Diğer Neighbor ID)” yapılır. Bunun için 4. Router’a “router ospf 1” altında “area 1 virtual-link 122.122.122.122” komutunu ve 2. Router’a “router ospf 1” altında “area 1 virtual-link 144.144.144.144” komutunu girmeliyiz. Komutları girdikten sonra kontrol edecek olursak;

ospf abr (area border router) konfigürasyonu
“4. VE 2. ROUTER ABR KONFİGÜRASYONU”

Şimdi ping testimiz yapabiliriz.

ospf ping testi
“OSPF PING TESTI”

Tüm router’lar yolları öğrenmiş ve erişim sağlanmış oldu.

Kullanılan Komutlar;

İsim Verme ve IP Atama;

1. Router için;

  • en
  • conf t
  • hostname R1
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • int ser 1/0
  • ip address 10.90.13.1 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 111.111.111.111 255.255.255.255
  • no shut
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname R2
  • int eth 0/0
  • ip address 10.90.124.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.24.2 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/3
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 122.122.122.122 255.255.255.255
  • no shut
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname R3
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int ser 1/0
  • ip address 10.90.13.3 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 133.133.133.133 255.255.255.255
  • no shut
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname R4
  • int eth 0/0
  • ip address 10.90.124.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.24.4 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.46.4 255.255.255.0
  • no shut
  • int eth 0/3
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 144.144.144.144 255.255.255.255
  • no shut
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname R5
  • int eth 0/0
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 155.155.155.155 255.255.255.255
  • no shut
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname R6
  • int eth 0/0
  • ip address 10.90.46.6 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 166.166.166.166 255.255.255.255
  • no shut
  • end
  • wr

 

OSPF Konfigürasyonu;

1. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.12.1 0.0.0.0 area 0
  • network 10.90.13.1 0.0.0.0 area 0
  • end
  • wr

2. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.12.2 0.0.0.0 area 0
  • network 10.90.23.2 0.0.0.0 area 0
  • network 10.90.24.2 0.0.0.0 area 1
  • network 10.90.124.2 0.0.0.0 area 1
  • end
  • wr

3. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.23.3 0.0.0.0 area 0
  • network 10.90.13.3 0.0.0.0 area 0
  • end
  • wr

4. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.24.4 0.0.0.0 area 1
  • network 10.90.45.4 0.0.0.0 area 2
  • network 10.90.46.4 0.0.0.0 area 2
  • network 10.90.124.4 0.0.0.0 area 1
  • end
  • wr

5. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.45.5 0.0.0.0 area 2
  • end
  • wr

6. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.46.6 0.0.0.0 area 2
  • end
  • wr

ABR Konfigürasyonu;

2. Router için;

  • en
  • conf t
  • router ospf 1
  • area 1 virtual-link 144.144.144.144
  • end
  • wr

4. Router için;

  • en
  • conf t
  • router ospf 1
  • area 1 virtual-link 122.122.122.122
  • end
  • wr

Test ve Komutları;

1. Router için;

  • ping 10.90.12.2
  • ping 10.90.46.6

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir