NETWORK LABORATUVARI

DERS 28- OSPF KİMLİK DOĞRULAMA (ENCRYPTED AUTHENTICATION)

Bu makalemizde MD5 ile şifreli kimlik doğrulamayı (authentication with MD5) laboratuvar ortamımızda test edeceğiz. MD5’ın açılımı “Message-Digest algorithm 5“tir. İsminden de anlaşılacağı üzere bir şifreleme algoritmasıdır.Bu algoritma ile veriden (data) kriptografik bir özet üretilir. Bu kriptografik özete “hash” denir. Üretilen hash’lere bakıldığında hiçbir şey anlaşılmaz yani verinin ne olduğu anlaşılamaz, karmakarışık bir şeydir. Zaten “hash”in Türkçe karşılığı “karışık şey”dir.

İlk olarak topolojimizi oluşturup, IP’lerimizi veriyoruz. Bunu daha önceki OSPF DİNAMİK ROUTING PROTOKOLÜ makalemizde yaptığımız için çok fazla detaylandırmayacağız.

ospf protokolü topoloji
“OSPF Protokolü İçin Örnek Topoloji”
ospf topology ip
“OSPF TOPOLOJİSİ İÇİN IP’LER”

IP verme işlemini daha önceki NETWORK CİHAZLARINA IP ATAMAK makalemizde anlattığımız için detaya girmeyeceğiz. Tüm IP’leri kontrol etmek için “show ip interface brief” komutunu kullanabiliriz. Daha önce öğrendiğimiz gibi topolojimizi area 0, area 1 ve area 2 olmak üzere area’lara bölerek OSPF çalıştıralım.

ospf area
“OSPF AREA’LAR”

Ping testi yapıp erişimin olduğunu teyit edelim.

ospf ping testi
“OSPF PING TESTI”

Ping testini diğer router’lar arasında yaptığımızda tüm router’ların yolları OSPF ile öğrenmişolduğunu göreceğiz. OSPF konuşan topolojimizde kimlik doğrulamalı OSPF ’i test edeceğiz. Artık şifreli kimlik doğrulama (encrypted  authentication) denememize başlayabiliriz.

Bu yöntem ile oluşturulan anahtar kelime açık metin şeklinde değil yani şifrelenmiş şekilde el sıkışılmak istenilen router ’lara gönderilir. Topolojimizde area 0 ‘da bulunan en sağdaki 1. ve 3. router ‘larda authentication işlemini yapalım. Bunun için iki router ‘da da birbirlerine bakan interface ’lerde yani serial interface’lerinde “ip ospf message-digest-key (anahtarlık rakamı) md5 (anahtar kelime)”komutu ile anahtarlığımızı ve anahtar kelimemizi girelim.  Anahtarlığımızın numarası “1”, anahtar kelimemiz “sifrenetwork” olsun.

OSPF Encrypted Authentication Configuration
“OSPF Encrypted Authentication Ayarları”

Şimdi de kimlik doğrulama ile anlaşmasını istediğimiz iki router’da da “router ospf 1” altında “area 0” alanında authentication işlemini “area 0 authentication” komutu ile aktif edelim. Ayrıca kontrol komutlarını kullanmadan önce işlem yaptığımız router’da “clear ip ospf process” komutu OSPF işlemi yeniden başlatacağı için önerilir. Bunu büyük sistemlerde yapmamak lazım çünkü sistemin tekrar ayağa kalkamaması gibi riskler olabilir.

OSPF Encrypted Authentication Configuration Test
“OSPF Encrypted Authentication Test”

Görüldüğü üzere “sh ip ospf neighbor” komutu ile bakıldığında 1. Router’ın tek komşusu var o da 3. Router. Aynı şekilde 3. Router’ın tek komşusu var o da 1. Router. Çünkü OSPF konfigürasyonunda authentication işlemi başlatılmış bu router’lar “ospf 1“ içerisinde sadece “1” numaralı anahtarlığa ve “sifrenetwork” key’ine sahip router’lar ile anlaşabilmiştir.

OSPF Encrypted Authentication Configuration Neighbor
“OSPF Encrypted Authentication Komşuluklar”

Ping testi de bunu doğrulamaktadır. Örneğin 5. router’dan 1. ve 3. router’a atılan ping başarısız olmuştur.

OSPF Encrypted Authentication Configuration Ping Test
“5. Router’dan 1. ve 3. Router’a Doğru Ping Testi”

Erişimin her bir router’da olması isteniyorsa bu authentication konfigürasyonu tüm router’larda yapılmalıdır.

Kullanılan Komutlar;

İsim Verme ve IP Atama;

1. Router için;

  • en
  • conf t
  • hostname R1
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • int ser 1/0
  • ip address 10.90.13.1 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 111.111.111.111 255.255.255.255
  • no shut
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname R2
  • int eth 0/0
  • ip address 10.90.124.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.24.2 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/3
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 122.122.122.122 255.255.255.255
  • no shut
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname R3
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int ser 1/0
  • ip address 10.90.13.3 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 133.133.133.133 255.255.255.255
  • no shut
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname R4
  • int eth 0/0
  • ip address 10.90.124.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.24.4 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.46.4 255.255.255.0
  • no shut
  • int eth 0/3
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 144.144.144.144 255.255.255.255
  • no shut
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname R5
  • int eth 0/0
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 155.155.155.155 255.255.255.255
  • no shut
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname R6
  • int eth 0/0
  • ip address 10.90.46.6 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 166.166.166.166 255.255.255.255
  • no shut
  • end
  • wr

OSPF Konfigürasyonu;

1. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.12.1 0.0.0.0 area 0
  • network 10.90.13.1 0.0.0.0 area 0
  • end
  • wr

2. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.12.2 0.0.0.0 area 0
  • network 10.90.23.2 0.0.0.0 area 0
  • network 10.90.24.2 0.0.0.0 area 1
  • network 10.90.124.2 0.0.0.0 area 1
  • end
  • wr

3. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.23.3 0.0.0.0 area 0
  • network 10.90.13.3 0.0.0.0 area 0
  • end
  • wr

4. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.24.4 0.0.0.0 area 1
  • network 10.90.45.4 0.0.0.0 area 2
  • network 10.90.46.4 0.0.0.0 area 2
  • network 10.90.124.4 0.0.0.0 area 1
  • end
  • wr

5. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.45.5 0.0.0.0 area 2
  • end
  • wr

6. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.46.6 0.0.0.0 area 2
  • end
  • wr

ABR Konfigürasyonu;

2. Router için;

  • en
  • conf t
  • router ospf 1
  • area 1 virtual-link 144.144.144.144
  • end
  • wr

4. Router için;

  • en
  • conf t
  • router ospf 1
  • area 1 virtual-link 122.122.122.122
  • end
  • wr

Encrypted Authentication Komutları;

1. Router için;

  • conf t
  • int serial 1/0
  • ip ospf authentication message-diggest-key 1 md5 sifrenetwork
  • exit
  • router ospf 1
  • area 0 authentication
  • end
  • wr

3. Router için;

  • conf t
  • int serial 1/0
  • ip ospf authentication message-diggest-key 1 md5 sifrenetwork
  • exit
  • router ospf 1
  • area 0 authentication
  • end
  • wr

Test ve Komutları;

1. Router için;

  • clear ip ospf process
  • yes
  • show ip ospf neighbor

3. Router için;

  • clear ip ospf process
  • yes
  • show ip ospf neighbor

5. Router için;

  • ping 10.90.12.1
  • ping 10.90.23.3

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir