NETWORK LABORATUVARI

DERS 29- OSPF KOMŞULUKLAR VE “show ip ospf neighbor” KOMUTU

OSPF KOMŞULUKLAR VE “show ip ospf neighbors” KOMUTU:

Topolojimizi oluşturup IP’leri verelim.

ospf topology ip
“OSPF TOPOLOJİSİ İÇİN IP’LER”

Daha önce öğrendiğimiz gibi topolojimizi area 0, area 1 ve area 2 olmak üzere area’lara bölerek OSPF çalıştıralım.

ospf area
“OSPF AREA’LAR”

Ping testi yapıp erişimin olduğunu teyit edelim.

ospf ping testi
“OSPF PING TESTI”

sh ip ospf neighbor” komutu ile router’ın OSPF komşuları görülebilir. Örneğin 1. Router ’ın komşularına baktığımızda “192.168.13.3” IP’li “Serial 1/0 interface”inden “133.133.133.133Neighbor ID’li router ile komşu olduğu 1.satırda belirtilmektedir. Aynı şekilde “10.90.12.2” IP’li “Ethernet 0/0 interface”inden “122.122.122.122Neighbor ID’li router ile komşu olduğu 2.satırda belirtilmektedir.

OSPF komşulular ve show ip ospf neighbor komutu ornek
“OSPF Komşulular ve show ip ospf neighbor Komutu”

Burada görüğümüz “Neigbor ID” o router içerisindeki en büyük IP otomatik olarak seçilir ve ya atanmış loopback adresleri varsa bunlardan en büyüğü veya “router-id xxxx” komutu ile el ile de yapılandırılabilir. Burada en büyük loopback adresini seçtiğini görüyoruz. Şimdi 3. Router’a el ile “3.3.3.3” şeklinde yani IP formatında bir Neighbor ID verelim. ARdından 3. router ’da “clear ip ospf process” komutu ile OSFP sürecini baştan başlatıyoruz.

bir cisco router'a router-id komutu ile ospf neighbor ID vermek
“Bir Router’a router-id Komutu İle OSPF Neighbor ID Vermek”

Şimdi de 1.Router ’da “sh ip ospf neighbor” komutu ile testini yapalım.

OSPF komşulular ve show ip ospf neighbor komutu ornek
“OSPF Komşulular ve show ip ospf neighbor Komutu”

3.Router ’ın “Neighbor ID” sinin değiştiğini görebiliyoruz.

Kullanılan Komutlar;

İsim Verme ve IP Atama;

1. Router için;

  • en
  • conf t
  • hostname R1
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • int ser 1/0
  • ip address 10.90.13.1 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 111.111.111.111 255.255.255.255
  • no shut
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname R2
  • int eth 0/0
  • ip address 10.90.124.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.24.2 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/3
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 122.122.122.122 255.255.255.255
  • no shut
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname R3
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int ser 1/0
  • ip address 10.90.13.3 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 133.133.133.133 255.255.255.255
  • no shut
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname R4
  • int eth 0/0
  • ip address 10.90.124.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.24.4 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.46.4 255.255.255.0
  • no shut
  • int eth 0/3
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 144.144.144.144 255.255.255.255
  • no shut
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname R5
  • int eth 0/0
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 155.155.155.155 255.255.255.255
  • no shut
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname R6
  • int eth 0/0
  • ip address 10.90.46.6 255.255.255.0
  • no shut
  • int loopback 0
  • ip address 166.166.166.166 255.255.255.255
  • no shut
  • end
  • wr

OSPF Konfigürasyonu;

1. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.12.1 0.0.0.0 area 0
  • network 10.90.13.1 0.0.0.0 area 0
  • end
  • wr

2. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.12.2 0.0.0.0 area 0
  • network 10.90.23.2 0.0.0.0 area 0
  • network 10.90.24.2 0.0.0.0 area 1
  • network 10.90.124.2 0.0.0.0 area 1
  • end
  • wr

3. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.23.3 0.0.0.0 area 0
  • network 10.90.13.3 0.0.0.0 area 0
  • end
  • wr

4. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.24.4 0.0.0.0 area 1
  • network 10.90.45.4 0.0.0.0 area 2
  • network 10.90.46.4 0.0.0.0 area 2
  • network 10.90.124.4 0.0.0.0 area 1
  • end
  • wr

5. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.45.5 0.0.0.0 area 2
  • end
  • wr

6. Router için;

  • en
  • conf t
  • router ospf 1
  • network 10.90.46.6 0.0.0.0 area 2
  • end
  • wr

ABR Konfigürasyonu;

2. Router için;

  • en
  • conf t
  • router ospf 1
  • area 1 virtual-link 144.144.144.144
  • end
  • wr

4. Router için;

  • en
  • conf t
  • router ospf 1
  • area 1 virtual-link 122.122.122.122
  • end
  • wr

Neighbor ID Değiştirme Komutları;

3. Router için;

  • conf t
  • router ospf 1
  • router-id 3.3.3.3
  • end
  • clear ip ospf process
  • yes

Test ve Komutları;

1. Router için;

  • ping 10.90.46.6
  • show ip ospf neighbor

 

 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir