NETWORK LABORATUVARI

DERS 15- EIGRP KOMŞULUKLAR

EIGRP KOMŞULUKLAR

“show ip eigrp neighbors” Komutu:

Topolojimizde daha önce öğrendiğimiz gibi EIGRP çalıştıralım. Bu konuyu DERS 11- EIGRP DİNAMİK ROUTING PROTOKOLÜ isimli makalemizde öğrendiğimiz için detaya inmeyeceğiz.

eigrp kontrol komutlari topoloji
“EIGRP KONTROL KOMUTLARI TOPOLOJİ”

Ping testleri ile router‘lar arası erişim olduğundan emin olalım.

eigrp redistribute ping testi başarılı
“BİRİNCİ ROUTER’DAN ALTINCI ROUTER’A ERİŞİM KONTROLÜ”

Bu kontrolü diğer router‘lar arasında da yapabiliriz. Sonuç olarak “EIGRP dinamik routing protokolü çalışıyor” diyebilmeliyiz. “show ip eigrp neighbors” komutu ile router’ların komşuları görülebilir. Hangi interface’inden hangi router ile komşu olduğunu öğrenebiliriz.

Örneğin topolojimize göre 1. Router’ın bir tane komşusu vardır. Yani 1. Router’ın “eth 0/0” interface’i ile “10.90.12.2” IP’li interface’e sahip router arasında (2. Router ile) komşuluk vardır. “show ip eigrp neighbors” kontrol komutumuz ile bunu görebiliriz.

eigrp kontrol komutları show ip eigrp neighbors komutu ile komşuluklar
“show ip eigrp neighbors KOMUTU”

Örneğin yine topolojimize baktığımızda 5. router’ın üç tane komşusu görünmektedir (3., 4. ve 6. router’dır). Yani;

  • 5.router’ın “eth 0/2” interface’i ile “10.90.56.6” IP’li interface’e sahip router arasında komşuluk vardır (yani 6. router ile komşudur).
  • 5.router’ın “eth 0/1” interface’i ile “10.90.45.4” IP’li interface’e sahip router arasında komşuluk vardır (yani 4. router ile komşudur).
  • 5.router’ın “eth 0/0” interface’i ile “10.90.35.3” IP’li interface’e sahip router arasında komşuluk vardır (yani 3. router ile komşudur).

5. router içerisinde “show ip eigrp neighbors” kontrol komutumuz ile bu komşuluklar kurulmuş mu kurulmamış mı? görebiliriz.

eigrp kontrol komutları show ip eigrp neighbors komutu ile komşulukların görülmesi
“show ip eigrp neighbors KOMUTU”

Bu makalemizde topolojide gördüğümüz komşulukları “show ip eigrp neighbors” kontrol komutu ile teyit ettik. Bazı durumlarda büyük sistemlere baktığımızda elimizde çizilmiş bir topoloji olmayabilir. Bundan dolayı bu komutlara ihtiyaç duyarız. Komşulukların tespiti ile EIGRP sistemine dahil router‘ları içeren topolojiyi kendimiz çizeriz.

Kullanılan Komutlar;

1. Router için;

  • en
  • conf t
  • hostname first_router
  • int eth 0/0
  • ip address 10.90.12.1 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.1 0.0.0.0
  • no auto-summry
  • end
  • wr

2. Router için;

  • en
  • conf t
  • hostname second_router
  • int eth 0/0
  • ip address 10.90.12.2 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.23.2 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.12.2 0.0.0.0
  • network 10.90.23.2 0.0.0.0
  • no auto-summry
  • end
  • wr

3. Router için;

  • en
  • conf t
  • hostname third_router
  • int eth 0/0
  • ip address 10.90.23.3 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.34.3 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.35.3 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.23.3 0.0.0.0
  • network 10.90.34.3 0.0.0.0
  • network 10.90.35.3 0.0.0.0
  • no auto-summry
  • end
  • wr

4. Router için;

  • en
  • conf t
  • hostname fourth_router
  • int eth 0/0
  • ip address 10.90.34.4 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.4 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.34.4 0.0.0.0
  • network 10.90.45.4 0.0.0.0
  • no auto-summry
  • end
  • wr

5. Router için;

  • en
  • conf t
  • hostname fifth_router
  • int eth 0/0
  • ip address 10.90.35.5 255.255.255.0
  • no shut
  • int eth 0/1
  • ip address 10.90.45.5 255.255.255.0
  • no shut
  • int eth 0/2
  • ip address 10.90.56.5 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.35.5 0.0.0.0
  • network 10.90.45.5 0.0.0.0
  • network 10.90.56.5 0.0.0.0
  • no auto-summry
  • end
  • wr

6. Router için;

  • en
  • conf t
  • hostname sixth_router
  • int eth 0/0
  • ip address 10.90.56.6 255.255.255.0
  • no shut
  • exit
  • router eigrp 34
  • network 10.90.56.6 0.0.0.0
  • no auto-summry
  • end
  • wr

Test ve Kontrol Komutları;

Tüm Router’lar için;

  • en
  • show ip eigrp neigbors

1. Router için;

  • ping 10.90.56.6

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir