NETWORK LABORATUVARI

Farklı Vlan’ları Haberleştirme

farkli vlanlari haberlestirme

Network laboratuvarımızda biraz da Layer 2 katmanında işlem yapalım. Tabi yönlendirme işlemi Layer 3’te gerçekleşek fakat Vlan’lar ile çalışacağız.

Layer 3 omurgalar üzerinden farklı Vlan’ları haberleştireceğiz. Aşağıda örnek topolojimiz görülüyor. Bu defa laboratuvar ortamı olarak Packet Tacer’ı kullandım.

farkli vlanlardan ping
“Farklı Vlan’ların Konuşmasına Dair Örnek Topoloji”

Senaryomuz: İki ayrı sahamız ve bu sahalarda saha Switch’lerimiz ile bilgisayarlarımız vardır. Her iki saha kendi içerisinde ayrı bir Vlan ile çalışmaktadır.

  • Saha-1 > Vlan 5
  • Saha-2 > Vlan 10

Her sahaya ait birer sistem merkezi var. Merkezler de birbiri ile irtibatlıdır. Saha-1 ve Saha-2’de çalışan bilgisayarlar ayrı ayrı Merkez-1 ve Merkez-2 sistem odalarında bulunan Layer 3 Omurga Switch’te sonlanmaktadır.

  • Saha-1 > Merkez-1
  • Saha-2 > Merkez-2

Amaç: Saha-1 ve Saha-2’de çalışan farklı bloklara ait sabit IP adresli bilgisayarların tamamı birbirleri ile haberleşebilmelidir. Yani farklı Vlan’ların konuşmasını sağlayacağız.

Yapılandırma Algoritması:

Önce hangi portlar Trunk gangi portlar Vlan 150, Vlan 5 ve Vlan 10 olacak onları planladık. Bilgisayaların IP adresleri, Gateway adresleri ve Vlan’ların IP bloklarını belirledik. Bunu da topoloji çizerek not aldık.

farkli vlanlarin haberlesmesi ornek
“Packet Tracer Ortamında Örnek Topoloji”

Artık konfigürasyona geçebiliriz. Aşağıdaki işlemleri yapacağız.

  • Bilgisayarların IP yapılandırması,
  • Saha Switch’lerinin Vlan ve Trunk yapılandırmaları,
  • Sistem merkezlerindeki omurga switch’lerin Vlan ve Trunk yapılandırmaları,
  • Farklı Vlanların haberleşmesi için Layer 3 omurgalarda statik route yazımı.

Saha-1 için;

Bilgisayarlara sabit olarak 192.168.5.1/24 ve 192.168.5.2/24 IP adresleri verilecek. Gateway IP adresi olarak da 192.168.5.150/24 adresleri verilecek. Aşağıda Saha-1’de bulunan Bilgisayar-1 için IP yapılandırma örneği verilmiştir. Diğer bilgisayarlar da buna benzer yapılandırılacak.

farkli vlanlarin haberlesmesi bilgisayar ip adresi
“Saha-1 Bilgisayarlarının IP Yapılandırması Örneği”

Saha switch’lerinde Vlan 5 oluşturulacak. “show vlan brief” komutu çıktısı aşağıdadır.

farkli vlanlarin haberlesmesi switch vlan
“Saha-1 Switch’leri Vlan Yapılandırması Örneği”

Tüm saha switch’lerinin FastEthernet 0/1 portları Vlan 5’e atanacak, böylece bu port sadece Vlan 5 için çalışacak. Ayrıca FastEthernet 0/2 portları trunk yapılacak, böylece bu porttan bütün Vlan’lara izin verilecek. “show running-config” komutu çıktısı aşağıdadır.

farkli vlanlarin haberlesmesi switch ayar
“Saha-1 Switch’leri Port Vlan ve Trunk Yapılandırması Örnek”

Saha-2 için;

Bilgisayarlara sabit olarak 192.168.10.1/24 ve 192.168.10.2/24 IP adresleri verilecek. Gateway IP adresi olarak da 192.168.5.150/24 adresleri verilecek. Aşağıda Saha-2’de bulunan Bilgisayar-3 için IP yapılandırma örneği verilmiştir. Diğer bilgisayarlar da buna benzer yapılandırılacak.

farkli vlanlarin haberlesmesi bilgisayar ip adresi
“Saha-2’deki Bilgisayarların IP Yapılandırması Örneği”

Saha Switch’lerinde Vlan 10 oluşturulacak. “show vlan brief” komutu çıktısı aşağıdadır.

farkli vlanlarin haberlesmesi konfigürasyon
“Saha-2 Switch’leri Vlan Yapılandırması”

Tüm saha switch’lerinin FastEthernet 0/1 portları Vlan 10’e atanacak, böylece bu port sadece Vlan 10 için çalışacak. Ayrıca FastEthernet 0/2 portları trunk yapılacak, böylece bu porttan bütün Vlan’lara izin verilecek.

farkli vlanlarin haberlesmesi calisma
“Saha-2 Switch’leri Port Vlan ve Trunk Yapılandırması Örnek”

Merkez-1 için;

Omurga-1’de FastEthernet 0/1, 0/2 ve 0/3 portları trunk yapılacak, böylece bu portlardan bütün Vlan’lara izin verilecek. “show running-config” komutu çıktısı aşağıdadır.

farkli vlanlarin konusması backbone
“Merkez-1 Omurga Trunk Yapılandırması Örnek”

Interface Vlan 5 oluşturulacak. 192.168.5.150/24 IP adresi verilecek.

Interface Vlan 150 oluşturulacak. 192.168.150.1/24 IP adresi verilecek. Burada Vlan 150, iki farklı Vlan’ın (Vlan 5 ve 10) Merkez omurgalar üzerinden konuşabilmesi için oluşturuluyor.

ip route 192.168.10.0 255.255.255.0 Vlan150 komutu ile statik bir route yazılacak. Bu route iki farklı Vlan’ın konuşması için yazılıyor.

farkli vlanlarin konusmasi layer 3 backbone
“Merkez-1 Omurga Vlan Yapılandırması ve Statik Route İşlemi”

Vlan 5, 10 ve 150 oluşturulacak. “Show vlan brief” komutu çıktısı aşağıdadır.

farkli vlanlarin konusmasi omurga tanimlama
“Merkez-1 Tanımlı Vlan’lar”

Merkez-2 için;

Omurga-2’de FastEthernet 0/1, 0/2 ve 0/3 portları trunk yapılacak, böylece bu portlardan bütün Vlan’lara izin verilecek. “show running-config” komutu çıktısı aşağıdadır.

farkli vlanlarin haberlesmesi backbone trunk
“Merkez-2 Omurgası Trunk Yapılandırması”

Interface Vlan 10 oluşturulacak. 192.168.10.150/24 IP adresi verilecek.

Interface Vlan 150 oluşturulacak. 192.168.150.2/24 IP adresi verilecek. Burada Vlan 150, iki farklı Vlan’ın (Vlan 5 ve 10) Merkez omurgalar üzerinden konuşabilmesi için oluşturuluyor.

ip route 192.168.5.0 255.255.255.0 Vlan150 komutu ile statik bir route yazılacak. Bu route iki farklı Vlan’ın konuşması için yazılıyor.

farkli vlanlarin haberlesmesi omurga vlan
“Merkez-2 Omurgası Vlan Yapılandırması ve Statik Route İşlemi”

Vlan 5, 10 ve 150 oluşturulacak. “Show vlan brief” komutu çıktısı aşağıdadır.

farkli vlanlarin iletisimi backbone
“Merkez-2 Omurgası Tanımlı Vlan’lar”

Test: Vlan 5’te çalışan 192.168.5.1 IP adresli bilgisayardan Vlan 10’da çalışan 192.168.10.2 IP adresli bilgisayar ping testi başarılı oldu.

farkli vlan ping atma
“Vlan 5’ten Vlan 10’a Ping Testi”

Haberleşme Vlan 5’teki bir bilgisayardan başlatıldı. Buradan çıkan paket Gateway IP adresine baktı ve kendi omurgasına kadar geldi. Oradan da route yardımıyla diğer merkezin omurgasına geçti. Oradan da Gateway IP adresi yardımıyla hedef bilgisayara ulaşmış oldu. Böylece farklı Vlanları haberleştirmiş olduk.

farklı vlanlardan ping atmak

Konfigürasyon Tamamı:

Bilgisayarlar;

IP Address: 192.168.X.X

Subnet Mask: 255.255.255.0

Default Gateway: 192.168.X.150

Saha Switch’leri;

  • enable
  • conf t
  • vlan X
  • name vlanX
  • exit
  • interface fastEthernet 0/1
  • switchport mode access
  • switchport access vlan X
  • no shut
  • exit
  • interface fastEthernet 0/2
  • switchport mode trunk
  • no shut
  • end
  • wr

Omurga Switch’ler;

  • enable
  • conf t
  • vlan 5
  • name vlan5
  • vlan 10
  • name vlan10
  • vlan 150
  • name vlan150
  • interface vlan X
  • ip address 192.168.X.150 255.255.255.0
  • no shut
  • interface vlan 150
  • ip address 192.168.150.X 255.255.255.0
  • no shut
  • exit
  • ip routing
  • ip route 192.168.X.0 255.255.255.0 Vlan150
  • interface range FastEthernet0/1 – 3
  • switchport trunk encapsulation dot1q
  • switchport mode trunk
  • no shut
  • end
  • wr

Test Komutları;

  • show running-config
  • show vlan brief
  • ping 192.168.X.X

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir